summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb')
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb22
1 files changed, 15 insertions, 7 deletions
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
index bb4a64ef8..9b2b6f322 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-dev.bb
@@ -5,19 +5,27 @@ python __anonymous() {
raise bb.parse.SkipRecipe(msg)
}
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
+LINUX_VERSION ?= "5.10.y"
+LINUX_RPI_BRANCH ?= "rpi-5.10.y"
-LINUX_VERSION ?= "4.19"
-LINUX_RPI_BRANCH ?= "rpi-4.19.y"
+SRCREV_machine = "${AUTOREV}"
+SRCREV_meta = "${AUTOREV}"
+
+KMETA = "kernel-meta"
-SRCREV = "${AUTOREV}"
SRC_URI = " \
- git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_BRANCH} \
+ git://github.com/raspberrypi/linux.git;name=machine;protocol=git;branch=${LINUX_RPI_BRANCH} \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=master;destsuffix=${KMETA} \
+ file://powersave.cfg \
+ file://android-drivers.cfg \
"
+
require linux-raspberrypi.inc
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+
+KERNEL_EXTRA_ARGS += "DTC_FLAGS='-@ -H epapr'"
+
# Disable version check so that we don't have to edit this recipe every time
# upstream bumps the version
KERNEL_VERSION_SANITY_SKIP = "1"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"