summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raspberrypi/recipes-kernel/linux')
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-rt_4.14.bb9
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc6
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb4
3 files changed, 13 insertions, 6 deletions
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-rt_4.14.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-rt_4.14.bb
new file mode 100644
index 000000000..1a990fe0f
--- /dev/null
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi-rt_4.14.bb
@@ -0,0 +1,9 @@
+LINUX_VERSION ?= "4.14.81"
+
+SRCREV = "acf578d07d57480674d5361df9171fe9528765cb"
+SRC_URI = " \
+ git://github.com/raspberrypi/linux.git;branch=rpi-4.14.y-rt \
+ file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \
+ "
+
+require linux-raspberrypi.inc
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
index 03acfb410..01f2425ed 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
@@ -35,8 +35,6 @@ CMDLINE_append += ' ${@oe.utils.conditional("DISABLE_RPI_BOOT_LOGO", "1", "logo.
CMDLINE_DEBUG ?= ""
CMDLINE_append = " ${CMDLINE_DEBUG}"
-KERNEL_INITRAMFS ?= '${@oe.utils.conditional("INITRAMFS_IMAGE_BUNDLE", "1", "1", "", d)}'
-
KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "stmpe-ts", "", d)}"
# A LOADADDR is needed when building a uImage format kernel. This value is not
@@ -101,7 +99,7 @@ do_configure_prepend() {
# Localversion
kernel_configure_variable LOCALVERSION "\"\""
- if [ ! -z "${KERNEL_INITRAMFS}" ]; then
+ if [ "${INITRAMFS_IMAGE_BUNDLE}" = "1" ]; then
kernel_configure_variable OVERLAY_FS y
kernel_configure_variable SQUASHFS y
kernel_configure_variable UBIFS_FS y
@@ -109,7 +107,7 @@ do_configure_prepend() {
# Activate the configuration options for VC4
VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
- if [ ${VC4GRAPHICS} = "1" ]; then
+ if [ "${VC4GRAPHICS}" = "1" ]; then
kernel_configure_variable I2C_BCM2835 y
kernel_configure_variable DRM y
kernel_configure_variable DRM_FBDEV_EMULATION y
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb
index 54936fa79..d11b59926 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.14.bb
@@ -1,6 +1,6 @@
-LINUX_VERSION ?= "4.14.68"
+LINUX_VERSION ?= "4.14.79"
-SRCREV = "8c8666ff6c1254d325cfa300d16f9928b3f31fc0"
+SRCREV = "9ca74c53cbda1f104bce3b33850fd3bf33eb3793"
SRC_URI = " \
git://github.com/raspberrypi/linux.git;branch=rpi-4.14.y \
file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \