summaryrefslogtreecommitdiff
path: root/meta-security/recipes-scanners/clamav/files/fix_systemd_socket.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-security/recipes-scanners/clamav/files/fix_systemd_socket.patch')
-rw-r--r--meta-security/recipes-scanners/clamav/files/fix_systemd_socket.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-security/recipes-scanners/clamav/files/fix_systemd_socket.patch b/meta-security/recipes-scanners/clamav/files/fix_systemd_socket.patch
index 3e9abe236..334777028 100644
--- a/meta-security/recipes-scanners/clamav/files/fix_systemd_socket.patch
+++ b/meta-security/recipes-scanners/clamav/files/fix_systemd_socket.patch
@@ -12,9 +12,9 @@ Index: git/clamd/CMakeLists.txt
===================================================================
--- git.orig/clamd/CMakeLists.txt
+++ git/clamd/CMakeLists.txt
-@@ -54,4 +54,10 @@ if(SYSTEMD_FOUND)
+@@ -60,4 +60,10 @@ if(SYSTEMD_FOUND)
install(
- FILES ${CMAKE_CURRENT_BINARY_DIR}/clamav-daemon.service
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/clamav-daemon.socket
DESTINATION ${SYSTEMD_UNIT_DIR})
+ configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/clamav-daemon.socket.in