summaryrefslogtreecommitdiff
path: root/meta-security/recipes-security/bastille
diff options
context:
space:
mode:
Diffstat (limited to 'meta-security/recipes-security/bastille')
-rw-r--r--meta-security/recipes-security/bastille/bastille_3.2.1.bb6
-rw-r--r--meta-security/recipes-security/bastille/files/AccountPermission.pm16
-rw-r--r--meta-security/recipes-security/bastille/files/FileContent.pm16
3 files changed, 19 insertions, 19 deletions
diff --git a/meta-security/recipes-security/bastille/bastille_3.2.1.bb b/meta-security/recipes-security/bastille/bastille_3.2.1.bb
index 0290cae2e..72281c537 100644
--- a/meta-security/recipes-security/bastille/bastille_3.2.1.bb
+++ b/meta-security/recipes-security/bastille/bastille_3.2.1.bb
@@ -6,8 +6,8 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
# Bash is needed for set +o privileged (check busybox), might also need ncurses
DEPENDS = "virtual/kernel"
-RDEPENDS_${PN} = "perl bash tcl perl-module-getopt-long perl-module-text-wrap lib-perl perl-module-file-path perl-module-mime-base64 perl-module-file-find perl-module-errno perl-module-file-glob perl-module-tie-hash-namedcapture perl-module-file-copy perl-module-english perl-module-exporter perl-module-cwd libcurses-perl coreutils"
-FILES_${PN} += "/run/lock/subsys/bastille"
+RDEPENDS:${PN} = "perl bash tcl perl-module-getopt-long perl-module-text-wrap lib-perl perl-module-file-path perl-module-mime-base64 perl-module-file-find perl-module-errno perl-module-file-glob perl-module-tie-hash-namedcapture perl-module-file-copy perl-module-english perl-module-exporter perl-module-cwd libcurses-perl coreutils"
+FILES:${PN} += "/run/lock/subsys/bastille"
SRC_URI = "http://sourceforge.net/projects/bastille-linux/files/bastille-linux/3.2.1/Bastille-3.2.1.tar.bz2 \
file://AccountPermission.pm \
@@ -150,4 +150,4 @@ do_install () {
ln -s RevertBastille ${D}${sbindir}/UndoBastille
}
-FILES_${PN} += "${datadir}/Bastille ${libdir}/Bastille ${libdir}/perl* ${sysconfdir}/*"
+FILES:${PN} += "${datadir}/Bastille ${libdir}/Bastille ${libdir}/perl* ${sysconfdir}/*"
diff --git a/meta-security/recipes-security/bastille/files/AccountPermission.pm b/meta-security/recipes-security/bastille/files/AccountPermission.pm
index cfbaab1d9..132b30ccb 100644
--- a/meta-security/recipes-security/bastille/files/AccountPermission.pm
+++ b/meta-security/recipes-security/bastille/files/AccountPermission.pm
@@ -16,7 +16,7 @@ B_chgrp
B_chgrp_link
B_userdel
B_groupdel
-B_remove_user_from_group
+B:remove_user_from_group
B_check_owner_group
B_is_unowned_file
B_is_ungrouped_file
@@ -28,7 +28,7 @@ B_is_suid
B_is_sgid
B_get_user_list
B_get_group_list
-B_remove_suid
+B:remove_suid
);
our @EXPORT = @EXPORT_OK;
@@ -74,7 +74,7 @@ sub B_chmod($$) {
if ($new_perm =~ /([ugo]+)([+-]{1})([rwxst]+)/) {
$symbolic = 1;
$chmod_noun = $1;
- $add_remove = $2;
+ $add:remove = $2;
$capability = $3;
}
@@ -466,7 +466,7 @@ sub B_chgrp_link($$) {
#
# In the future, we may also choose to make a B_lock_account routine.
#
-# This routine depends on B_remove_user_from_group.
+# This routine depends on B:remove_user_from_group.
###########################################################################
sub B_userdel($) {
@@ -506,7 +506,7 @@ sub B_userdel($) {
#
# Next find out what groups the user is in, so we can call
- # B_remove_user_from_group($user,$group)
+ # B:remove_user_from_group($user,$group)
#
# TODO: add this to the helper functions for the test suite.
#
@@ -586,7 +586,7 @@ sub B_groupdel($) {
###########################################################################
-# B_remove_user_from_group($user,$group) removes $user from $group,
+# B:remove_user_from_group($user,$group) removes $user from $group,
# by modifying $group's /etc/group line, pulling the user out. This
# uses B_chunk_replace thrice to replace these patterns:
#
@@ -595,7 +595,7 @@ sub B_groupdel($) {
#
###########################################################################
-sub B_remove_user_from_group($$) {
+sub B:remove_user_from_group($$) {
my ($user_to_remove,$group) = @_;
@@ -1022,7 +1022,7 @@ sub B_get_group_list()
#
###########################################################################
-sub B_remove_suid($) {
+sub B:remove_suid($) {
my $file_expr = $_[0];
&B_log("ACTION","Removing SUID bit from \"$file_expr\".");
diff --git a/meta-security/recipes-security/bastille/files/FileContent.pm b/meta-security/recipes-security/bastille/files/FileContent.pm
index 0a5d6096c..1ef89dd76 100644
--- a/meta-security/recipes-security/bastille/files/FileContent.pm
+++ b/meta-security/recipes-security/bastille/files/FileContent.pm
@@ -10,8 +10,8 @@ B_blank_file
B_insert_line_after
B_insert_line_before
B_insert_line
-B_append_line
-B_prepend_line
+B:append_line
+B:prepend_line
B_replace_line
B_replace_lines
B_replace_pattern
@@ -262,7 +262,7 @@ sub B_insert_line($$$$) {
#
# Additionally, if $pattern is set equal to "", the line is always appended.
#
-# B_append_line uses B_open_plus and B_close_plus, so that the file
+# B:append_line uses B_open_plus and B_close_plus, so that the file
# modified is backed up...
#
# Here's examples of where you might use this:
@@ -273,7 +273,7 @@ sub B_insert_line($$$$) {
#
###########################################################################
-sub B_append_line($$$) {
+sub B:append_line($$$) {
my ($filename,$pattern,$line_to_append) = @_;
@@ -308,11 +308,11 @@ sub B_append_line($$$) {
###########################################################################
# &B_prepend_line ($filename,$pattern,$line_to_prepend) modifies $filename,
-# pre-pending $line_to_prepend unless one or more lines in the file matches
+# pre-pending $line_to:prepend unless one or more lines in the file matches
# $pattern. This is an enhancement to the prepend_line_if_no_such_line_exists
# idea.
#
-# B_prepend_line uses B_open_plus and B_close_plus, so that the file
+# B:prepend_line uses B_open_plus and B_close_plus, so that the file
# modified is backed up...
#
# Here's examples of where you might use this:
@@ -322,7 +322,7 @@ sub B_append_line($$$) {
#
###########################################################################
-sub B_prepend_line($$$) {
+sub B:prepend_line($$$) {
my ($filename,$pattern,$line_to_prepend) = @_;
@@ -348,7 +348,7 @@ sub B_prepend_line($$$) {
# Log the action
&B_log("ACTION","Pre-pended the following line to $filename:\n");
- &B_log("ACTION","$line_to_prepend");
+ &B_log("ACTION","$line_to:prepend");
}
else {
$retval=0;