summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot')
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/files/0001-Remove-redundant-YYLOC-global-declaration.patch28
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-spl-zynq-init.inc70
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx-dev.bb28
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx.inc20
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2020.2.bb23
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb96
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.qspi.versal1
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.versal3
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.zynq7
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.zynqmp9
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/pxeboot.pxe4
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-uenv.bb110
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot_%.bbappend11
13 files changed, 0 insertions, 410 deletions
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/files/0001-Remove-redundant-YYLOC-global-declaration.patch b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/files/0001-Remove-redundant-YYLOC-global-declaration.patch
deleted file mode 100644
index 7091098ca..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/files/0001-Remove-redundant-YYLOC-global-declaration.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 8127b19aa42ccfb3faae1173a12b3eb0cebf8941 Mon Sep 17 00:00:00 2001
-From: Peter Robinson <pbrobinson@gmail.com>
-Date: Thu, 30 Jan 2020 09:37:15 +0000
-Subject: [PATCH] Remove redundant YYLOC global declaration
-
-Same as the upstream fix for building dtc with gcc 10.
-
-Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
-State: upstream (e33a814e772cdc36436c8c188d8c42d019fda639)
----
- scripts/dtc/dtc-lexer.l | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/scripts/dtc/dtc-lexer.l b/scripts/dtc/dtc-lexer.l
-index fd825ebba6..24af549977 100644
---- a/scripts/dtc/dtc-lexer.l
-+++ b/scripts/dtc/dtc-lexer.l
-@@ -38,7 +38,6 @@ LINECOMMENT "//".*\n
- #include "srcpos.h"
- #include "dtc-parser.tab.h"
-
--YYLTYPE yylloc;
- extern bool treesource_error;
-
- /* CAUTION: this will stop working if we ever use yyless() or yyunput() */
---
-2.29.2
-
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-spl-zynq-init.inc b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-spl-zynq-init.inc
deleted file mode 100644
index 97c449bd3..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-spl-zynq-init.inc
+++ /dev/null
@@ -1,70 +0,0 @@
-inherit xilinx-platform-init
-
-FORCE_PLATFORM_INIT[doc] = "This variable is used to force the overriding of all platform init files in u-boot source."
-
-PLATFORM_BOARD_DIR ?= ""
-PLATFORM_BOARD_DIR_zynq = "board/xilinx/zynq"
-PLATFORM_BOARD_DIR_zynqmp = "board/xilinx/zynqmp"
-
-do_zynq_platform_init() {
- for f in ${PLATFORM_INIT_FILES}; do
- if [ -d "${S}/${PLATFORM_BOARD_DIR}/custom_hw_platform" ]; then
- cp ${PLATFORM_INIT_STAGE_DIR}/$f ${S}/${PLATFORM_BOARD_DIR}/custom_hw_platform/
- else
- cp ${PLATFORM_INIT_STAGE_DIR}/$f ${S}/${PLATFORM_BOARD_DIR}/
- fi
- # Newer u-boot sources use the init files in a sub directory named
- # based on the name of the device tree. This is not straight forward to
- # detect. Instead of detecting just overwrite all the platform init
- # files so that the correct one is always used. This shotgun approach
- # only works due to this recipe being machine arch specific. Do this
- # overwrite un-conditionally as there is no guarantees that the chosen
- # board config does not have the device tree config set.
- for i in ${S}/${PLATFORM_BOARD_DIR}/*/; do
- [ -d $i ] && cp ${PLATFORM_INIT_STAGE_DIR}/$f $i
- done
- done
-}
-
-python () {
- # strip the tail _config/_defconfig for better comparison
- def strip_config_name(c):
- for i in ["_config", "_defconfig"]:
- if c.endswith(i):
- return c[0:len(c) - len(i)]
- return c
-
- if d.getVar("SOC_FAMILY") not in ["zynq", "zynqmp"]:
- # continue on this is not a zynq/zynqmp target
- return
-
- # Determine if target machine needs to provide a custom platform init files
- if d.getVar("SPL_BINARY"):
- hasconfigs = [strip_config_name(c) for c in (d.getVar("HAS_PLATFORM_INIT") or "").split()]
- currentconfig = strip_config_name(d.getVar("UBOOT_MACHINE"))
-
- # only add the dependency if u-boot doesn't already provide the platform init files
- if (currentconfig not in hasconfigs) or (d.getVar("FORCE_PLATFORM_INIT") == "1"):
- # force the dependency on a recipe that provides the platform init files
- d.appendVar("DEPENDS", " virtual/xilinx-platform-init")
- # setup task to modify platform init after unpack and prepare_recipe_sysroot, and before configure
- bb.build.addtask("do_zynq_platform_init", "do_configure", "do_unpack do_prepare_recipe_sysroot", d)
-
- if "boot.bin" not in d.getVar("SPL_BINARY"):
- # not deploying the boot.bin, just building SPL
- return
-
- # assume that U-Boot is to provide the boot.bin if no other provides are selected or U-Boot is selected
- providesbin = not(d.getVar("PREFERRED_PROVIDER_virtual/boot-bin")) or d.getVar("PREFERRED_PROVIDER_virtual/boot-bin") == d.getVar("PN")
- if providesbin:
- # add provides, if U-Boot is set to provide boot.bin
- d.appendVar("PROVIDES", " virtual/boot-bin")
- else:
- # prevent U-Boot from deploying the boot.bin
- d.setVar("SPL_BINARY", "")
-
- if providesbin and d.getVar("SOC_FAMILY") in ["zynqmp"]:
- # setup PMU Firmware path via MAKEFLAGS
- d.appendVar("EXTRA_OEMAKE", " CONFIG_PMUFW_INIT_FILE=\"{0}\"".format("${PMU_FIRMWARE_DEPLOY_DIR}/${PMU_FIRMWARE_IMAGE_NAME}.bin"))
-}
-
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx-dev.bb b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx-dev.bb
deleted file mode 100644
index 3e40bfa17..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx-dev.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-# This recipe allows for a 'bleeding edge' u-boot-xlnx build.
-# Since this tree is frequently updated, AUTOREV is used to track its contents.
-#
-# To enable this recipe, set the following in your machine or local.conf
-# PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-xlnx-dev"
-
-UBRANCH ?= "master"
-
-include u-boot-xlnx.inc
-include u-boot-spl-zynq-init.inc
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c"
-
-SRCREV_DEFAULT = "aebea9d20a5aa32857f320c07ca8f9fd1b3dec1f"
-SRCREV ?= "${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/bootloader", "u-boot-xlnx-dev", "${AUTOREV}", "${SRCREV_DEFAULT}", d)}"
-
-PV = "${UBRANCH}-xilinx-dev+git${SRCPV}"
-
-# Newer versions of u-boot have support for these
-HAS_PLATFORM_INIT ?= " \
- zynq_microzed_config \
- zynq_zed_config \
- zynq_zc702_config \
- zynq_zc706_config \
- zynq_zybo_config \
- "
-
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx.inc b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx.inc
deleted file mode 100644
index 4b8c4efee..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx.inc
+++ /dev/null
@@ -1,20 +0,0 @@
-require recipes-bsp/u-boot/u-boot.inc
-
-DEPENDS += "bc-native dtc-native bison-native"
-
-XILINX_RELEASE_VERSION ?= ""
-UBOOT_VERSION_EXTENSION ?= "-xilinx-${XILINX_RELEASE_VERSION}"
-PV = "${UBOOT_VERSION}${UBOOT_VERSION_EXTENSION}+git${SRCPV}"
-
-UBOOTURI ?= "git://github.com/Xilinx/u-boot-xlnx.git;protocol=https"
-UBRANCH ?= ""
-UBRANCHARG = "${@['nobranch=1', 'branch=${UBRANCH}'][d.getVar('UBRANCH', True) != '']}"
-
-SRC_URI = "${UBOOTURI};${UBRANCHARG}"
-
-S = "${WORKDIR}/git"
-B = "${WORKDIR}/build"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
-
-SYSROOT_DIRS += "/boot"
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2020.2.bb b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2020.2.bb
deleted file mode 100644
index 95c7254c6..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2020.2.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-UBOOT_VERSION = "v2020.01"
-
-UBRANCH ?= "xlnx_rebase_v2020.01"
-
-SRCREV ?= "bb4660c33aa7ea64f78b2682bf0efd56765197d6"
-
-include u-boot-xlnx.inc
-include u-boot-spl-zynq-init.inc
-
-# Patch required for latest gcc and 2020.2 version of u-boot-xlnx
-# This will be removed once the SRCREV above has been updated to include this change
-SRC_URI += " file://0001-Remove-redundant-YYLOC-global-declaration.patch"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://README;beginline=1;endline=4;md5=744e7e3bb0c94b4b9f6b3db3bf893897"
-
-# u-boot-xlnx has support for these
-HAS_PLATFORM_INIT ?= " \
- xilinx_zynqmp_virt_config \
- xilinx_zynq_virt_defconfig \
- xilinx_versal_vc_p_a2197_revA_x_prc_01_revA \
- "
-
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
deleted file mode 100644
index e8b91922b..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
+++ /dev/null
@@ -1,96 +0,0 @@
-SUMMARY = "U-boot boot scripts for Xilinx devices"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-DEPENDS = "u-boot-mkimage-native"
-
-inherit deploy nopackages image-wic-utils
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-COMPATIBLE_MACHINE ?= "^$"
-COMPATIBLE_MACHINE_zynqmp = "zynqmp"
-COMPATIBLE_MACHINE_zynq = "zynq"
-COMPATIBLE_MACHINE_versal = "versal"
-
-KERNELDT = "${@os.path.basename(d.getVar('KERNEL_DEVICETREE').split(' ')[0]) if d.getVar('KERNEL_DEVICETREE') else ''}"
-DEVICE_TREE_NAME ?= "${@bb.utils.contains('PREFERRED_PROVIDER_virtual/dtb', 'device-tree', 'system.dtb', d.getVar('KERNELDT'), d)}"
-#Need to copy a rootfs.cpio.gz.u-boot as uramdisk.image.gz into boot partition
-RAMDISK_IMAGE ?= ""
-RAMDISK_IMAGE_zynq ?= "uramdisk.image.gz"
-
-KERNEL_BOOTCMD_zynqmp ?= "booti"
-KERNEL_BOOTCMD_zynq ?= "bootm"
-KERNEL_BOOTCMD_versal ?= "booti"
-
-BOOTMODE ?= "sd"
-
-SRC_URI = " \
- file://boot.cmd.sd.zynq \
- file://boot.cmd.sd.zynqmp \
- file://boot.cmd.sd.versal \
- file://boot.cmd.qspi.versal \
- file://pxeboot.pxe \
- "
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-UBOOTSCR_BASE_NAME ?= "${PN}-${PKGE}-${PKGV}-${PKGR}${IMAGE_VERSION_SUFFIX}"
-UBOOTPXE_CONFIG ?= "pxelinux.cfg"
-UBOOTPXE_CONFIG_NAME = "${UBOOTPXE_CONFIG}${IMAGE_VERSION_SUFFIX}"
-
-DEVICETREE_ADDRESS_zynqmp ?= "0x100000"
-DEVICETREE_ADDRESS_zynq ?= "0x2000000"
-DEVICETREE_ADDRESS_versal ?= "0x1000"
-KERNEL_LOAD_ADDRESS_zynqmp ?= "0x200000"
-KERNEL_LOAD_ADDRESS_zynq ?= "0x2080000"
-KERNEL_LOAD_ADDRESS_versal ?= "0x80000"
-
-RAMDISK_IMAGE_ADDRESS_zynq ?= "0x4000000"
-RAMDISK_IMAGE_ADDRESS_versal ?= "0x6000000"
-
-
-SDBOOTDEV ?= "0"
-
-BITSTREAM_LOAD_ADDRESS ?= "0x100000"
-
-do_configure[noexec] = "1"
-do_install[noexec] = "1"
-
-def get_bitstream_load_type(d):
- if boot_files_bitstream(d)[1] :
- return "loadb"
- else:
- return "load"
-
-do_compile() {
- sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \
- -e 's/@@KERNEL_LOAD_ADDRESS@@/${KERNEL_LOAD_ADDRESS}/' \
- -e 's/@@DEVICE_TREE_NAME@@/${DEVICE_TREE_NAME}/' \
- -e 's/@@DEVICETREE_ADDRESS@@/${DEVICETREE_ADDRESS}/' \
- -e 's/@@RAMDISK_IMAGE@@/${RAMDISK_IMAGE}/' \
- -e 's/@@RAMDISK_IMAGE_ADDRESS@@/${RAMDISK_IMAGE_ADDRESS}/' \
- -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \
- -e 's/@@SDBOOTDEV@@/${SDBOOTDEV}/' \
- -e 's/@@BITSTREAM@@/${@boot_files_bitstream(d)[0]}/g' \
- -e 's/@@BITSTREAM_LOAD_ADDRESS@@/${BITSTREAM_LOAD_ADDRESS}/g' \
- -e 's/@@BITSTREAM_IMAGE@@/${@boot_files_bitstream(d)[0]}/g' \
- -e 's/@@BITSTREAM_LOAD_TYPE@@/${@get_bitstream_load_type(d)}/g' \
- "${WORKDIR}/boot.cmd.${BOOTMODE}.${SOC_FAMILY}" > "${WORKDIR}/boot.cmd"
- mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
- sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \
- -e 's/@@DEVICE_TREE_NAME@@/${DEVICE_TREE_NAME}/' \
- -e 's/@@RAMDISK_IMAGE@@/${RAMDISK_IMAGE}/' \
- "${WORKDIR}/pxeboot.pxe" > "pxeboot.pxe"
-}
-
-
-do_deploy() {
- install -d ${DEPLOYDIR}
- install -m 0644 boot.scr ${DEPLOYDIR}/${UBOOTSCR_BASE_NAME}.scr
- ln -sf ${UBOOTSCR_BASE_NAME}.scr ${DEPLOYDIR}/boot.scr
- install -d ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME}
- install -m 0644 pxeboot.pxe ${DEPLOYDIR}/pxeboot/${UBOOTPXE_CONFIG_NAME}/default
- ln -sf pxeboot/${UBOOTPXE_CONFIG_NAME} ${DEPLOYDIR}/${UBOOTPXE_CONFIG}
-}
-
-addtask do_deploy after do_compile before do_build
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.qspi.versal b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.qspi.versal
deleted file mode 100644
index d56b7c8cd..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.qspi.versal
+++ /dev/null
@@ -1 +0,0 @@
-@@KERNEL_BOOTCMD@@ @@KERNEL_LOAD_ADDRESS@@ @@RAMDISK_IMAGE_ADDRESS@@ @@DEVICETREE_ADDRESS@@
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.versal b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.versal
deleted file mode 100644
index 10e83cd09..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.versal
+++ /dev/null
@@ -1,3 +0,0 @@
-setenv bootargs $bootargs root=/dev/mmcblk0p2 rw rootwait clk_ignore_unused
-fatload mmc $sdbootdev:$partid @@KERNEL_LOAD_ADDRESS@@ @@KERNEL_IMAGETYPE@@
-@@KERNEL_BOOTCMD@@ @@KERNEL_LOAD_ADDRESS@@ - @@DEVICETREE_ADDRESS@@
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.zynq b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.zynq
deleted file mode 100644
index bbd2e01e9..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.zynq
+++ /dev/null
@@ -1,7 +0,0 @@
-if test -n "@@BITSTREAM@@"; then
- fatload mmc $sdbootdev @@BITSTREAM_LOAD_ADDRESS@@ @@BITSTREAM_IMAGE@@ && fpga @@BITSTREAM_LOAD_TYPE@@ 0 @@BITSTREAM_LOAD_ADDRESS@@ ${filesize}
-fi
-fatload mmc 0 @@DEVICETREE_ADDRESS@@ @@DEVICE_TREE_NAME@@
-fatload mmc 0 @@KERNEL_LOAD_ADDRESS@@ @@KERNEL_IMAGETYPE@@
-fatload mmc 0 @@RAMDISK_IMAGE_ADDRESS@@ @@RAMDISK_IMAGE@@
-@@KERNEL_BOOTCMD@@ @@KERNEL_LOAD_ADDRESS@@ @@RAMDISK_IMAGE_ADDRESS@@ @@DEVICETREE_ADDRESS@@
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.zynqmp b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.zynqmp
deleted file mode 100644
index 43062ce8f..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/boot.cmd.sd.zynqmp
+++ /dev/null
@@ -1,9 +0,0 @@
-setenv sdbootdev @@SDBOOTDEV@@
-setenv bootargs $bootargs root=/dev/mmcblk${sdbootdev}p2 rw rootwait earlycon clk_ignore_unused
-setenv bootargs $bootargs root=/dev/mmcblk0p2 rw rootwait earlycon clk_ignore_unused
-if test -n "@@BITSTREAM@@"; then
- fatload mmc $sdbootdev @@BITSTREAM_LOAD_ADDRESS@@ @@BITSTREAM_IMAGE@@ && fpga @@BITSTREAM_LOAD_TYPE@@ 0 @@BITSTREAM_LOAD_ADDRESS@@ ${filesize}
-fi
-fatload mmc $sdbootdev @@DEVICETREE_ADDRESS@@ @@DEVICE_TREE_NAME@@
-fatload mmc $sdbootdev:$partid @@KERNEL_LOAD_ADDRESS@@ @@KERNEL_IMAGETYPE@@
-@@KERNEL_BOOTCMD@@ @@KERNEL_LOAD_ADDRESS@@ - @@DEVICETREE_ADDRESS@@
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/pxeboot.pxe b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/pxeboot.pxe
deleted file mode 100644
index 407965453..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/pxeboot.pxe
+++ /dev/null
@@ -1,4 +0,0 @@
-LABEL Linux
-KERNEL @@KERNEL_IMAGETYPE@@
-FDT @@DEVICE_TREE_NAME@@
-INITRD @@RAMDISK_IMAGE@@
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-uenv.bb b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-uenv.bb
deleted file mode 100644
index 6e4c3c0b2..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-uenv.bb
+++ /dev/null
@@ -1,110 +0,0 @@
-SUMMARY = "U-Boot uEnv.txt SD boot environment generation for Zynq targets"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-INHIBIT_DEFAULT_DEPS = "1"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-python () {
- # The device trees must be populated in the deploy directory to correctly
- # detect them and their names. This means that this recipe needs to depend
- # on those deployables just like the image recipe does.
- deploydeps = ["virtual/kernel"]
- for i in (d.getVar("MACHINE_ESSENTIAL_EXTRA_RDEPENDS") or "").split():
- if i != d.getVar("BPN"):
- deploydeps.append(i)
- for i in (d.getVar("EXTRA_IMAGEDEPENDS") or "").split():
- if i != d.getVar("BPN"):
- deploydeps.append(i)
-
- # add as DEPENDS since the targets might not have do_deploy tasks
- if len(deploydeps) != 0:
- d.appendVar("DEPENDS", " " + " ".join(deploydeps))
-}
-
-COMPATIBLE_MACHINE = "^$"
-COMPATIBLE_MACHINE_zynq = ".*"
-COMPATIBLE_MACHINE_zynqmp = ".*"
-
-inherit deploy image-wic-utils
-
-def uboot_boot_cmd(d):
- if d.getVar("KERNEL_IMAGETYPE") in ["uImage", "fitImage"]:
- return "bootm"
- if d.getVar("KERNEL_IMAGETYPE") in ["zImage"]:
- return "bootz"
- if d.getVar("KERNEL_IMAGETYPE") in ["Image"]:
- return "booti"
- raise bb.parse.SkipRecipe("Unsupport kernel image type")
-
-def get_sdbootdev(d):
- if d.getVar("SOC_FAMILY") in ["zynqmp"]:
- return "${sdbootdev}"
- else:
- return "0"
-
-def uenv_populate(d):
- # populate the environment values
- env = {}
-
- env["machine_name"] = d.getVar("MACHINE")
-
- env["kernel_image"] = d.getVar("KERNEL_IMAGETYPE")
- env["kernel_load_address"] = d.getVar("KERNEL_LOAD_ADDRESS")
-
- env["devicetree_image"] = boot_files_dtb_filepath(d)
- env["devicetree_load_address"] = d.getVar("DEVICETREE_LOAD_ADDRESS")
-
- env["bootargs"] = d.getVar("KERNEL_BOOTARGS")
-
- env["loadkernel"] = "fatload mmc " + get_sdbootdev(d) + " ${kernel_load_address} ${kernel_image}"
- env["loaddtb"] = "fatload mmc " + get_sdbootdev(d) + " ${devicetree_load_address} ${devicetree_image}"
- env["bootkernel"] = "run loadkernel && run loaddtb && " + uboot_boot_cmd(d) + " ${kernel_load_address} - ${devicetree_load_address}"
-
- if d.getVar("SOC_FAMILY") in ["zynqmp"]:
- env["bootkernel"] = "setenv bootargs " + d.getVar("KERNEL_BOOTARGS") + " ; " + env["bootkernel"]
-
- # default uenvcmd does not load bitstream
- env["uenvcmd"] = "run bootkernel"
-
- bitstream, bitstreamtype = boot_files_bitstream(d)
- if bitstream:
- env["bitstream_image"] = bitstream
- env["bitstream_load_address"] = "0x100000"
-
- # if bitstream is "bit" format use loadb, otherwise use load
- env["bitstream_type"] = "loadb" if bitstreamtype else "load"
-
- # load bitstream first with loadfpa
- env["loadfpga"] = "fatload mmc " + get_sdbootdev(d) + " ${bitstream_load_address} ${bitstream_image} && fpga ${bitstream_type} 0 ${bitstream_load_address} ${filesize}"
- env["uenvcmd"] = "run loadfpga && run bootkernel"
-
- return env
-
-# bootargs, default to booting with the rootfs device being partition 2
-KERNEL_BOOTARGS_zynq = "earlyprintk console=ttyPS0,115200 root=/dev/mmcblk0p2 rw rootwait"
-KERNEL_BOOTARGS_zynqmp = "earlycon clk_ignore_unused root=/dev/mmcblk${sdbootdev}p2 rw rootwait"
-
-KERNEL_LOAD_ADDRESS_zynq = "0x2080000"
-KERNEL_LOAD_ADDRESS_zynqmp = "0x80000"
-DEVICETREE_LOAD_ADDRESS_zynq = "0x2000000"
-DEVICETREE_LOAD_ADDRESS_zynqmp = "0x4000000"
-
-python do_compile() {
- env = uenv_populate(d)
- with open(d.expand("${WORKDIR}/uEnv.txt"), "w") as f:
- for k, v in env.items():
- f.write("{0}={1}\n".format(k, v))
-}
-
-FILES_${PN} += "/boot/uEnv.txt"
-
-do_install() {
- install -Dm 0644 ${WORKDIR}/uEnv.txt ${D}/boot/uEnv.txt
-}
-
-do_deploy() {
- install -Dm 0644 ${WORKDIR}/uEnv.txt ${DEPLOYDIR}/uEnv.txt
-}
-addtask do_deploy after do_compile before do_build
-
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
deleted file mode 100644
index b85223699..000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
+++ /dev/null
@@ -1,11 +0,0 @@
-include u-boot-spl-zynq-init.inc
-
-# u-boot 2016.11 has support for these
-HAS_PLATFORM_INIT ??= " \
- zynq_microzed_config \
- zynq_zed_config \
- zynq_zc702_config \
- zynq_zc706_config \
- zynq_zybo_config \
- "
-