summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb')
-rwxr-xr-xmeta-xilinx/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb
new file mode 100755
index 000000000..e5356d865
--- /dev/null
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Xilinx DisplayPort Linux Kernel module"
+DESCRIPTION = "Out-of-tree DisplayPort(DP) kernel modules provider for aarch64 devices"
+SECTION = "kernel/modules"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eb723b61539feef013de476e68b5c50a"
+
+XLNX_DP_VERSION = "5.4.0"
+PV = "${XLNX_DP_VERSION}"
+
+S = "${WORKDIR}/git"
+
+BRANCH ?= "master"
+REPO ?= "git://github.com/xilinx/dp-modules.git;protocol=https"
+SRCREV ?= "a3a7dfe17cf610fd4186b11638e1ce6b78dc958a"
+
+BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
+SRC_URI = "${REPO};${BRANCHARG}"
+
+inherit module
+
+EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}"
+COMPATIBLE_MACHINE = "^$"
+COMPATIBLE_MACHINE_zynqmp = "zynqmp"
+COMPATIBLE_MACHINE_versal = "versal"
+
+PACKAGE_ARCH = "${SOC_FAMILY_ARCH}"