summaryrefslogtreecommitdiff
path: root/meta-yadro/meta-nicole/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-yadro/meta-nicole/recipes-phosphor')
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/configuration/nicole-yaml-config/nicole-ipmi-fru-properties.yaml2
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/host/p9-host-start.bbappend1
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend1
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/leds/nicole-led-manager-config/led.yaml18
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend6
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/sensors/phosphor-hwmon/obmc/hwmon/iio-hwmon-battery.conf9
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend3
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json10
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/state/phosphor-state-manager/resetreason.conf2
-rw-r--r--meta-yadro/meta-nicole/recipes-phosphor/state/phosphor-state-manager_%.bbappend5
10 files changed, 46 insertions, 11 deletions
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/configuration/nicole-yaml-config/nicole-ipmi-fru-properties.yaml b/meta-yadro/meta-nicole/recipes-phosphor/configuration/nicole-yaml-config/nicole-ipmi-fru-properties.yaml
index ba2c91818..472679d76 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/configuration/nicole-yaml-config/nicole-ipmi-fru-properties.yaml
+++ b/meta-yadro/meta-nicole/recipes-phosphor/configuration/nicole-yaml-config/nicole-ipmi-fru-properties.yaml
@@ -43,3 +43,5 @@
<<: *DEFAULTS
/system/chassis/motherboard/dimm15:
<<: *DEFAULTS
+/system/chassis/motherboard/opfw:
+ <<: *DEFAULTS
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/host/p9-host-start.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/host/p9-host-start.bbappend
index 83ef5455a..d26a4d696 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/host/p9-host-start.bbappend
+++ b/meta-yadro/meta-nicole/recipes-phosphor/host/p9-host-start.bbappend
@@ -1,2 +1 @@
RDEPENDS_${PN}_append = " avsbus-control"
-RDEPENDS_${PN}_remove = " p9-vcs-workaround"
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
index 5ac83a8c1..16d815ade 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
+++ b/meta-yadro/meta-nicole/recipes-phosphor/ipmi/phosphor-ipmi-fru_%.bbappend
@@ -2,4 +2,5 @@ DEPENDS_append = " nicole-yaml-config"
EXTRA_OECONF = " \
YAML_GEN=${STAGING_DIR_HOST}${datadir}/nicole-yaml-config/ipmi-fru-read.yaml \
+ PROP_YAML=${STAGING_DIR_HOST}${datadir}/nicole-yaml-config/ipmi-extra-properties.yaml \
"
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/leds/nicole-led-manager-config/led.yaml b/meta-yadro/meta-nicole/recipes-phosphor/leds/nicole-led-manager-config/led.yaml
index 9ce2e2989..beb8c9870 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/leds/nicole-led-manager-config/led.yaml
+++ b/meta-yadro/meta-nicole/recipes-phosphor/leds/nicole-led-manager-config/led.yaml
@@ -1,17 +1,27 @@
+#
+# If the LED has a label in DTS like:
+# label = "device:color:function";
+# the D-Bus name looks like:
+# device_function_color
+#
+bmc_booted:
+ platform_power_green:
+ Action: 'Blink'
+ Priority: 'On'
power_on:
- power:
+ platform_power_green:
Action: 'On'
Priority: 'On'
enclosure_identify:
- identify:
+ platform_indicator_blue:
Action: 'Blink'
Priority: 'Blink'
enclosure_fault: &SYS_FAULT
- alarm_red:
+ platform_fault_red:
Action: 'Blink'
Priority: 'Blink'
enclosure_warning: &FRU_FAULT
- alarm_yellow:
+ platform_alarm_yellow:
Action: 'Blink'
Priority: 'Blink'
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index ce3a6494d..8ad3a91eb 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-yadro/meta-nicole/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1,2 +1,6 @@
RDEPENDS_${PN}-inventory_append = " openpower-occ-control"
-RDEPENDS_${PN}-extras += " phosphor-hostlogger openpower-esel-parser"
+RDEPENDS_${PN}-extras_append = " \
+ phosphor-hostlogger \
+ openpower-esel-parser \
+ obmc-yadro-fwupdate \
+"
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/sensors/phosphor-hwmon/obmc/hwmon/iio-hwmon-battery.conf b/meta-yadro/meta-nicole/recipes-phosphor/sensors/phosphor-hwmon/obmc/hwmon/iio-hwmon-battery.conf
new file mode 100644
index 000000000..290a72252
--- /dev/null
+++ b/meta-yadro/meta-nicole/recipes-phosphor/sensors/phosphor-hwmon/obmc/hwmon/iio-hwmon-battery.conf
@@ -0,0 +1,9 @@
+LABEL_in1=vbat
+GAIN_in1=2.25
+
+# GPIOP2 needs to be pulled high for battery voltage reading
+GPIOCHIP_in1=0
+GPIO_in1=122
+
+# Read it every day so it does not impact battery life
+INTERVAL=86400000000
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
index d03b2c40f..58e0c90b3 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
+++ b/meta-yadro/meta-nicole/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -2,6 +2,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
EXTRA_OECONF_append = " --enable-negative-errno-on-fail"
+ITEMS = "iio-hwmon-battery.conf"
+
OCCS = " \
00--00--00--06/sbefifo1-dev0/occ-hwmon.1 \
00--00--00--0a/fsi-master/fsi1/slave@01--00/01--01--00--06/sbefifo2-dev0/occ-hwmon.2 \
@@ -11,4 +13,5 @@ OCCSFMT = "devices/platform/gpio-fsi/fsi-master/fsi0/slave@00--00/{0}.conf"
OCCITEMS = "${@compose_list(d, 'OCCSFMT', 'OCCS')}"
ENVS = "obmc/hwmon/{0}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}_append = " ${@compose_list(d, 'ENVS', 'ITEMS')}"
SYSTEMD_ENVIRONMENT_FILE_${PN}_append = " ${@compose_list(d, 'ENVS', 'OCCITEMS')}"
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-yadro/meta-nicole/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
index 96644622b..cfc3b4a75 100644
--- a/meta-yadro/meta-nicole/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
+++ b/meta-yadro/meta-nicole/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -29,11 +29,6 @@
"direction": "in"
},
{
- "name": "BMC_WD_CLEAR_PULSE_N",
- "pin": "N5",
- "direction": "falling"
- },
- {
"name": "CHECKSTOP",
"pin": "J2",
"direction": "falling"
@@ -42,6 +37,11 @@
"name": "POWER_BUTTON",
"pin": "O2",
"direction": "both"
+ },
+ {
+ "name": "ID_BTN",
+ "pin": "Q7",
+ "direction": "out"
}
]
}
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/state/phosphor-state-manager/resetreason.conf b/meta-yadro/meta-nicole/recipes-phosphor/state/phosphor-state-manager/resetreason.conf
new file mode 100644
index 000000000..828d98b8e
--- /dev/null
+++ b/meta-yadro/meta-nicole/recipes-phosphor/state/phosphor-state-manager/resetreason.conf
@@ -0,0 +1,2 @@
+[Unit]
+ConditionKernelCommandLine=resetreason=power
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-yadro/meta-nicole/recipes-phosphor/state/phosphor-state-manager_%.bbappend
new file mode 100644
index 000000000..dcf8cac00
--- /dev/null
+++ b/meta-yadro/meta-nicole/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+DEPS_CFG = "resetreason.conf"
+DEPS_TGT = "phosphor-discover-system-state@.service"
+SYSTEMD_OVERRIDE_${PN}-discover_append = "${DEPS_CFG}:${DEPS_TGT}.d/${DEPS_CFG}"