summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-core/util-linux/util-linux_2.37.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-core/util-linux/util-linux_2.37.2.bb')
-rw-r--r--poky/meta/recipes-core/util-linux/util-linux_2.37.2.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/poky/meta/recipes-core/util-linux/util-linux_2.37.2.bb b/poky/meta/recipes-core/util-linux/util-linux_2.37.2.bb
index 935159514..d609c3006 100644
--- a/poky/meta/recipes-core/util-linux/util-linux_2.37.2.bb
+++ b/poky/meta/recipes-core/util-linux/util-linux_2.37.2.bb
@@ -37,12 +37,13 @@ python util_linux_binpackages () {
continue
pkg = os.path.basename(os.readlink(file))
- extras[pkg] = extras.get(pkg, '') + ' ' + file.replace(dvar, '', 1)
+ extras.setdefault(pkg, [])
+ extras[pkg].append(file.replace(dvar, '', 1))
pn = d.getVar('PN')
for pkg, links in extras.items():
of = d.getVar('FILES:' + pn + '-' + pkg)
- links = of + links
+ links = of + " " + " ".join(sorted(links))
d.setVar('FILES:' + pn + '-' + pkg, links)
}
@@ -73,7 +74,7 @@ EXTRA_OECONF = "\
\
--disable-bfs --disable-login \
--disable-makeinstall-chown --disable-minix --disable-newgrp \
- --disable-use-tty-group --disable-vipw \
+ --disable-use-tty-group --disable-vipw --disable-raw \
\
--without-udev \
\