summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-core/volatile-binds/volatile-binds.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-core/volatile-binds/volatile-binds.bb')
-rw-r--r--poky/meta/recipes-core/volatile-binds/volatile-binds.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/poky/meta/recipes-core/volatile-binds/volatile-binds.bb b/poky/meta/recipes-core/volatile-binds/volatile-binds.bb
index 3c8b18291..b693c24c4 100644
--- a/poky/meta/recipes-core/volatile-binds/volatile-binds.bb
+++ b/poky/meta/recipes-core/volatile-binds/volatile-binds.bb
@@ -33,9 +33,9 @@ def volatile_systemd_services(d):
services.append("%s.service" % what[1:].replace("/", "-"))
return " ".join(services)
-SYSTEMD_SERVICE_${PN} = "${@volatile_systemd_services(d)}"
+SYSTEMD_SERVICE:${PN} = "${@volatile_systemd_services(d)}"
-FILES_${PN} += "${systemd_unitdir}/system/*.service ${servicedir}"
+FILES:${PN} += "${systemd_unitdir}/system/*.service ${servicedir}"
do_compile () {
while read spec mountpoint; do
@@ -68,7 +68,7 @@ do_install () {
install -m 0755 mount-copybind ${D}${base_sbindir}/
install -d ${D}${systemd_unitdir}/system
- for service in ${SYSTEMD_SERVICE_${PN}}; do
+ for service in ${SYSTEMD_SERVICE:${PN}}; do
install -m 0644 $service ${D}${systemd_unitdir}/system/
done