summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-hypothesis_6.14.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-hypothesis_6.14.5.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-hypothesis_6.14.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-hypothesis_6.14.5.bb b/poky/meta/recipes-devtools/python/python3-hypothesis_6.14.5.bb
new file mode 100644
index 000000000..0460a4319
--- /dev/null
+++ b/poky/meta/recipes-devtools/python/python3-hypothesis_6.14.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A library for property-based testing"
+HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
+
+PYPI_PACKAGE = "hypothesis"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "0563b9711fd9bf478cb591580a575c369d2c396f283efa85d0f9a75b26db65b5"
+
+RDEPENDS:${PN} += " \
+ python3-attrs \
+ python3-compression \
+ python3-core \
+ python3-json \
+ python3-sortedcontainers \
+ python3-statistics \
+ python3-unittest \
+ "
+
+BBCLASSEXTEND = "native nativesdk"