summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-magic_0.4.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-magic_0.4.18.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-magic_0.4.18.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-magic_0.4.18.bb b/poky/meta/recipes-devtools/python/python3-magic_0.4.18.bb
new file mode 100644
index 000000000..be423adac
--- /dev/null
+++ b/poky/meta/recipes-devtools/python/python3-magic_0.4.18.bb
@@ -0,0 +1,19 @@
+SUMMARY = "File type identification using libmagic"
+DESCRIPTION = "This module uses ctypes to access the libmagic file type \
+ identification library. It makes use of the local magic database and supports \
+ both textual and MIME-type output."
+HOMEPAGE = "http://github.com/ahupp/python-magic"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16a934f165e8c3245f241e77d401bb88"
+
+PYPI_PACKAGE = "python-magic"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "5edc6caa39cc62641850f6b1b6f284ba"
+SRC_URI[sha256sum] = "b757db2a5289ea3f1ced9e60f072965243ea43a2221430048fd8cacab17be0ce"
+
+RDEPENDS_${PN} += "file"
+
+BBCLASSEXTEND = "native"