summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-devtools/python/python3-packaging_21.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-devtools/python/python3-packaging_21.0.bb')
-rw-r--r--poky/meta/recipes-devtools/python/python3-packaging_21.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/poky/meta/recipes-devtools/python/python3-packaging_21.0.bb b/poky/meta/recipes-devtools/python/python3-packaging_21.0.bb
new file mode 100644
index 000000000..23ecd9df5
--- /dev/null
+++ b/poky/meta/recipes-devtools/python/python3-packaging_21.0.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Core utilities for Python packages"
+HOMEPAGE = "https://github.com/pypa/packaging"
+LICENSE = "Apache-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
+
+SRC_URI[sha256sum] = "7dc96269f53a4ccec5c0670940a4281106dd0bb343f47b7471f779df49c2fbe7"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing"