summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-extended/mdadm/mdadm_4.1.bb')
-rw-r--r--poky/meta/recipes-extended/mdadm/mdadm_4.1.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb b/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb
index 9862a38dc..597faf787 100644
--- a/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb
+++ b/poky/meta/recipes-extended/mdadm/mdadm_4.1.bb
@@ -17,9 +17,9 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \
file://0001-Compute-abs-diff-in-a-standard-compliant-way.patch \
file://0001-fix-gcc-8-format-truncation-warning.patch \
+ file://debian-no-Werror.patch \
file://mdadm.init \
file://mdmonitor.service \
- file://0001-mdadm-gcc8-maybe-uninitialized-format-overflow-warni.patch \
"
SRC_URI[md5sum] = "51bf3651bd73a06c413a2f964f299598"
SRC_URI[sha256sum] = "ab7688842908d3583a704d491956f31324c3a5fc9f6a04653cb75d19f1934f4a"
@@ -57,13 +57,15 @@ do_install() {
do_install_append() {
install -d ${D}/${sysconfdir}/
install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf
- install -d ${D}/${systemd_unitdir}/system
- install -m 644 ${WORKDIR}/mdmonitor.service ${D}/${systemd_unitdir}/system
- install -m 644 ${S}/systemd/mdmon@.service ${D}/${systemd_unitdir}/system
install -d ${D}/${sysconfdir}/init.d
install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor
}
+do_install_append() {
+ oe_runmake install-systemd DESTDIR=${D}
+}
+
+
do_compile_ptest() {
oe_runmake test
}
@@ -90,3 +92,5 @@ RRECOMMENDS_${PN}-ptest += " \
kernel-module-raid10 \
kernel-module-raid456 \
"
+
+FILES_${PN} += "/lib/systemd/*"