summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb')
-rw-r--r--poky/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb18
1 files changed, 15 insertions, 3 deletions
diff --git a/poky/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb b/poky/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
index e97731073..e163a6948 100644
--- a/poky/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
+++ b/poky/meta/recipes-extended/net-tools/net-tools_1.60-20181103.bb
@@ -16,8 +16,6 @@ SRC_URI = "git://git.code.sf.net/p/net-tools/code;protocol=https \
file://Bug_541172-netstat.c-exit-codes.patch \
"
-UPSTREAM_VERSION_UNKNOWN = "1"
-
S = "${WORKDIR}/git"
inherit gettext
@@ -107,4 +105,18 @@ python __anonymous() {
}
ALTERNATIVE_PRIORITY = "100"
-BBCLASSEXTEND = "native nativesdk"
+NETTOOLS_PACKAGES = "${PN}-mii-tool"
+NETTOOLS_PACKAGES_class-native = ""
+
+PACKAGE_BEFORE_PN = "${NETTOOLS_PACKAGES}"
+RDEPENDS_${PN} += "${NETTOOLS_PACKAGES}"
+
+FILES_${PN}-mii-tool = "${base_sbindir}/mii-tool"
+
+ALTERNATIVE_${PN}_remove = "mii-tool"
+
+ALTERNATIVE_${PN}-mii-tool = "mii-tool"
+ALTERNATIVE_TARGET[mii-tool] = "${base_sbindir}/mii-tool"
+ALTERNATIVE_LINK_NAME[mii-tool] = "${base_sbindir}/mii-tool"
+
+BBCLASSEXTEND = "native nativesdk" \ No newline at end of file