summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-extended/pam/libpam_1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-extended/pam/libpam_1.3.1.bb')
-rw-r--r--poky/meta/recipes-extended/pam/libpam_1.3.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/poky/meta/recipes-extended/pam/libpam_1.3.1.bb b/poky/meta/recipes-extended/pam/libpam_1.3.1.bb
index b58b9ac5f..adc641505 100644
--- a/poky/meta/recipes-extended/pam/libpam_1.3.1.bb
+++ b/poky/meta/recipes-extended/pam/libpam_1.3.1.bb
@@ -128,6 +128,13 @@ python populate_packages_prepend () {
do_split_packages(d, pam_filterdir, r'^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
}
+do_compile_ptest() {
+ cd tests
+ sed -i -e 's/$(MAKE) $(AM_MAKEFLAGS) check-TESTS//' Makefile
+ oe_runmake check-am
+ cd -
+}
+
do_install() {
autotools_do_install
@@ -147,6 +154,13 @@ do_install() {
fi
}
+do_install_ptest() {
+ if [ ${PTEST_ENABLED} = "1" ]; then
+ mkdir -p ${D}${PTEST_PATH}/tests
+ install -m 0755 ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests
+ fi
+}
+
inherit features_check
REQUIRED_DISTRO_FEATURES = "pam"