summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-graphics/mesa/mesa_19.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-graphics/mesa/mesa_19.0.3.bb')
-rw-r--r--poky/meta/recipes-graphics/mesa/mesa_19.0.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/poky/meta/recipes-graphics/mesa/mesa_19.0.3.bb b/poky/meta/recipes-graphics/mesa/mesa_19.0.3.bb
new file mode 100644
index 000000000..585c3ede2
--- /dev/null
+++ b/poky/meta/recipes-graphics/mesa/mesa_19.0.3.bb
@@ -0,0 +1,19 @@
+require ${BPN}.inc
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
+ file://0001-Simplify-wayland-scanner-lookup.patch \
+ file://0002-winsys-svga-drm-Include-sys-types.h.patch \
+ file://0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
+ file://0004-use-PKG_CHECK_VAR-for-defining-WAYLAND_PROTOCOLS_DAT.patch \
+"
+
+SRC_URI[md5sum] = "d03bf14e42c0e54ebae5730712ccc408"
+SRC_URI[sha256sum] = "f027244e38dc309a4c12db45ef79be81ab62c797a50a88d566e4edb6159fc4d5"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}