summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb')
-rw-r--r--poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb26
1 files changed, 11 insertions, 15 deletions
diff --git a/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb b/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
index ee9b11837..73aa0ee96 100644
--- a/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
+++ b/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
@@ -8,26 +8,22 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRCREV = "0dbd899941a43ffd55df527d65128b3b66e75c9c"
SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
- file://0001-Fix-the-link-order-of-libglslang-and-libHLSL.patch \
- file://0003-cmake-de-vendor-libs-and-disable-git-versioning.patch \
+ file://0001-cmake-disable-building-external-dependencies.patch \
+ file://0002-libshaderc_util-fix-glslang-header-file-location.patch \
+ file://0003-cmake-add-option-to-skip-build-the-examples.patch \
"
+UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$"
S = "${WORKDIR}/git"
inherit cmake python3native
-DEPENDS = "spirv-tools glslang"
+DEPENDS = "spirv-headers spirv-tools glslang"
-EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DSHADERC_SKIP_TESTS=ON"
-
-do_configure_prepend() {
- # TODO: probably there is better solution for this.
- # I dont know any method for get the version of a receipe in DEPENDS
- # so do this ugly hack
- cat <<- EOF > ${S}/glslc/src/build-version.inc
-"${PV}\\n"
-"$(pkg-config --modversion SPIRV-Tools)\\n"
-"$(glslangValidator --version | head -1 | cut -d' ' -f3)\\n"
-EOF
-}
+EXTRA_OECMAKE = " \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_EXTERNAL=OFF \
+ -DSHADERC_SKIP_TESTS=ON \
+ -DSHADERC_SKIP_EXAMPLES=ON \
+"
BBCLASSEXTEND = "native nativesdk"