summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb')
-rw-r--r--poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb20
1 files changed, 5 insertions, 15 deletions
diff --git a/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb b/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
index e966ed3d7..73aa0ee96 100644
--- a/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
+++ b/poky/meta/recipes-graphics/shaderc/shaderc_2020.4.bb
@@ -8,7 +8,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRCREV = "0dbd899941a43ffd55df527d65128b3b66e75c9c"
SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
- file://0001-cmake-de-vendor-libs-and-disable-git-versioning.patch \
+ file://0001-cmake-disable-building-external-dependencies.patch \
+ file://0002-libshaderc_util-fix-glslang-header-file-location.patch \
+ file://0003-cmake-add-option-to-skip-build-the-examples.patch \
"
UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$"
S = "${WORKDIR}/git"
@@ -19,21 +21,9 @@ DEPENDS = "spirv-headers spirv-tools glslang"
EXTRA_OECMAKE = " \
-DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_EXTERNAL=OFF \
-DSHADERC_SKIP_TESTS=ON \
- -Dglslang_SOURCE_DIR=${STAGING_INCDIR}/glslang \
+ -DSHADERC_SKIP_EXAMPLES=ON \
"
BBCLASSEXTEND = "native nativesdk"
-
-# TODO: probably there is better solution for this.
-# I don't know any method for get the version of a receipe in DEPENDS,
-# so do this ugly hack
-inherit pkgconfig
-DEPENDS += "glslang-native"
-do_configure_prepend() {
- cat <<- EOF > ${S}/glslc/src/build-version.inc
-"${PV}\\n"
-"$(pkg-config --modversion SPIRV-Tools)\\n"
-"$(glslangValidator --version | head -1 | cut -d' ' -f3)\\n"
-EOF
-}