summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-graphics/vulkan/vulkan-samples_git.bb')
-rw-r--r--poky/meta/recipes-graphics/vulkan/vulkan-samples_git.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/poky/meta/recipes-graphics/vulkan/vulkan-samples_git.bb b/poky/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
index 896b24832..b7c38f654 100644
--- a/poky/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
+++ b/poky/meta/recipes-graphics/vulkan/vulkan-samples_git.bb
@@ -1,15 +1,17 @@
DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
+HOMEPAGE = "https://www.khronos.org/vulkan/"
+BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git \
file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
- file://0001-support-link-against-libatomic-if-no-built-in-atomic.patch \
+ file://debugfix.patch \
"
UPSTREAM_CHECK_COMMITS = "1"
-SRCREV = "fdc8fab1a520df5566de3eda7b526b24f04e6379"
+SRCREV = "55cebd9e7cc4153a3a7b3a45d42274c0e2a17815"
UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
S = "${WORKDIR}/git"
@@ -19,3 +21,14 @@ REQUIRED_DISTRO_FEATURES = 'vulkan'
inherit cmake features_check
FILES_${PN} += "${datadir}"
+
+#
+# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
+# used for logging with LOGE in the code. We need to make this match the value we use
+# in the debug source remapping from CFLAGS
+#
+EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
+# Binaries built with PCH enabled don't appear reproducible, differing results were seen
+# from some builds depending on the point the PCH was compiled. Disable it to be
+# deterministic
+EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"