summaryrefslogtreecommitdiff
path: root/poky/meta/recipes-support/gnupg/gnupg_2.2.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'poky/meta/recipes-support/gnupg/gnupg_2.2.17.bb')
-rw-r--r--poky/meta/recipes-support/gnupg/gnupg_2.2.17.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/poky/meta/recipes-support/gnupg/gnupg_2.2.17.bb b/poky/meta/recipes-support/gnupg/gnupg_2.2.17.bb
index 689cf8a75..bb8885f1c 100644
--- a/poky/meta/recipes-support/gnupg/gnupg_2.2.17.bb
+++ b/poky/meta/recipes-support/gnupg/gnupg_2.2.17.bb
@@ -29,6 +29,21 @@ EXTRA_OECONF = "--disable-ldap \
--with-readline=${STAGING_LIBDIR}/.. \
--enable-gpg-is-gpg2 \
"
+
+# A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg)
+PACKAGES =+ "${PN}-gpg"
+FILES_${PN}-gpg = " \
+ ${bindir}/gpg \
+ ${bindir}/gpg2 \
+ ${bindir}/gpg-agent \
+"
+
+# Normal package (gnupg) should depend on minimal package (gnupg-gpg)
+# to ensure all tools are included. This is done only in non-native
+# builds. Native builds don't have sub-packages, so appending RDEPENDS
+# in this case breaks recipe parsing.
+RDEPENDS_${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}"
+
RRECOMMENDS_${PN} = "pinentry"
do_configure_prepend () {
@@ -55,4 +70,4 @@ PACKAGECONFIG ??= "gnutls"
PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"