summaryrefslogtreecommitdiff
path: root/yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb')
-rw-r--r--yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb
deleted file mode 100644
index c5cd7a97b..000000000
--- a/yocto-poky/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY = "The canonical example of init scripts"
-SECTION = "base"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
-
-SRC_URI = "file://skeleton \
- file://skeleton_test.c \
- file://COPYRIGHT \
- "
-
-do_compile () {
- ${CC} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
-}
-
-do_install () {
- install -d ${D}${sysconfdir}/init.d
- cat ${WORKDIR}/skeleton | \
- sed -e 's,/etc,${sysconfdir},g' \
- -e 's,/usr/sbin,${sbindir},g' \
- -e 's,/var,${localstatedir},g' \
- -e 's,/usr/bin,${bindir},g' \
- -e 's,/usr,${prefix},g' > ${D}${sysconfdir}/init.d/skeleton
- chmod a+x ${D}${sysconfdir}/init.d/skeleton
-
- install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
-}
-
-RDEPENDS_${PN} = "initscripts"
-
-CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton"