summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-bsp/apmd/apmd_3.2.2-15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta/recipes-bsp/apmd/apmd_3.2.2-15.bb')
-rw-r--r--yocto-poky/meta/recipes-bsp/apmd/apmd_3.2.2-15.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-bsp/apmd/apmd_3.2.2-15.bb b/yocto-poky/meta/recipes-bsp/apmd/apmd_3.2.2-15.bb
index ea105268a..4ff6ad087 100644
--- a/yocto-poky/meta/recipes-bsp/apmd/apmd_3.2.2-15.bb
+++ b/yocto-poky/meta/recipes-bsp/apmd/apmd_3.2.2-15.bb
@@ -13,6 +13,8 @@ SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_3.2.2.orig.tar.gz;name=tarball \
file://legacy.patch \
file://libtool.patch \
file://unlinux.patch \
+ file://wexitcode.patch \
+ file://linkage.patch \
file://init \
file://default \
file://apmd_proxy \
@@ -22,6 +24,10 @@ SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_3.2.2.orig.tar.gz;name=tarball \
SRC_URI[tarball.md5sum] = "b1e6309e8331e0f4e6efd311c2d97fa8"
SRC_URI[tarball.sha256sum] = "7f7d9f60b7766b852881d40b8ff91d8e39fccb0d1d913102a5c75a2dbb52332d"
+# for this package we're mostly interested in tracking debian patches,
+# and not in the upstream version where all development has effectively stopped
+UPSTREAM_CHECK_REGEX = "(?P<pver>((\d+\.*)+)-((\d+\.*)+))\.(diff|debian\.tar)\.(gz|xz)"
+
S = "${WORKDIR}/apmd-3.2.2.orig"
inherit update-rc.d systemd
@@ -32,6 +38,8 @@ INITSCRIPT_PARAMS = "defaults"
SYSTEMD_SERVICE_${PN} = "apmd.service"
SYSTEMD_AUTO_ENABLE = "disable"
+EXTRA_OEMAKE = "-e MAKEFLAGS="
+
do_compile() {
# apmd doesn't use whole autotools. Just libtool for installation
oe_runmake "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" apm apmd