summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb')
-rw-r--r--yocto-poky/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb27
1 files changed, 20 insertions, 7 deletions
diff --git a/yocto-poky/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb b/yocto-poky/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
index fa7aa62eb..bc250080f 100644
--- a/yocto-poky/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
+++ b/yocto-poky/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
@@ -17,13 +17,20 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
file://msggen.pl.patch \
file://reautoconf.patch \
file://user-declared-default-constructor.patch \
- file://fix-regex.patch"
+ file://fix-regex.patch \
+ file://no-libtool.patch"
SRC_URI[md5sum] = "7df692e3186109cc00db6825b777201e"
SRC_URI[sha256sum] = "1d2d7996cc94f9b87d0c51cf0e028070ac177c4123ecbfd7ac1cb8d0b7d322d1"
+UPSTREAM_CHECK_URI = "http://openjade.sourceforge.net/download.html"
+
inherit autotools-brokensep native
+# Statically link local libs to avoid gold link issue [YOCTO #2972]
+PACKAGECONFIG ?= "static-only-libs"
+PACKAGECONFIG[static-only-libs] = "--enable-static --disable-shared,--enable-static --enable-shared,,"
+
EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
--enable-splibdir=${STAGING_LIBDIR}"
@@ -57,14 +64,20 @@ do_compile_prepend () {
do_install() {
# Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html
# for details.
- install -d ${D}${bindir}
- install -m 0755 ${S}/jade/.libs/openjade ${D}${bindir}/openjade
+ install -d ${D}${bindir} ${D}${libdir}
+ if ${@bb.utils.contains('PACKAGECONFIG', 'static-only-libs', 'true', 'false', d)}; then
+ install -m 0755 jade/openjade ${D}${bindir}/openjade
+ oe_libinstall -a -C style libostyle ${D}${libdir}
+ oe_libinstall -a -C spgrove libospgrove ${D}${libdir}
+ oe_libinstall -a -C grove libogrove ${D}${libdir}
+ else
+ install -m 0755 jade/.libs/openjade ${D}${bindir}/openjade
+ oe_libinstall -a -so -C style libostyle ${D}${libdir}
+ oe_libinstall -a -so -C spgrove libospgrove ${D}${libdir}
+ oe_libinstall -a -so -C grove libogrove ${D}${libdir}
+ fi
ln -sf openjade ${D}${bindir}/jade
- oe_libinstall -a -so -C style libostyle ${D}${libdir}
- oe_libinstall -a -so -C spgrove libospgrove ${D}${libdir}
- oe_libinstall -a -so -C grove libogrove ${D}${libdir}
-
install -d ${D}${datadir}/sgml/openjade-${PV}
install -m 644 dsssl/catalog ${D}${datadir}/sgml/openjade-${PV}
install -m 644 dsssl/*.dtd ${D}${datadir}/sgml/openjade-${PV}