summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-directfb.bb
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-directfb.bb')
-rw-r--r--yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-directfb.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-directfb.bb b/yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-directfb.bb
new file mode 100644
index 000000000..53dc0ae19
--- /dev/null
+++ b/yocto-poky/meta/recipes-graphics/packagegroups/packagegroup-core-directfb.bb
@@ -0,0 +1,17 @@
+SUMMARY = "DirectFB without X11"
+LICENSE = "MIT"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+TOUCH = ' ${@bb.utils.contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
+
+RDEPENDS_${PN} = " \
+ directfb \
+ directfb-examples \
+ pango \
+ pango-modules \
+ fontconfig \
+ ${TOUCH} \
+"