summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-graphics/wayland/weston-init.bb
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta/recipes-graphics/wayland/weston-init.bb')
-rw-r--r--yocto-poky/meta/recipes-graphics/wayland/weston-init.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/yocto-poky/meta/recipes-graphics/wayland/weston-init.bb b/yocto-poky/meta/recipes-graphics/wayland/weston-init.bb
index 38b78bcd0..653541e3c 100644
--- a/yocto-poky/meta/recipes-graphics/wayland/weston-init.bb
+++ b/yocto-poky/meta/recipes-graphics/wayland/weston-init.bb
@@ -1,19 +1,28 @@
-SUMMARY = "Startup script for the Weston Wayland compositor"
+SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
-SRC_URI = "file://init"
+SRC_URI = "file://init \
+ file://weston.service"
S = "${WORKDIR}"
do_install() {
install -d ${D}/${sysconfdir}/init.d
install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}
}
-inherit allarch update-rc.d
+inherit allarch update-rc.d distro_features_check systemd
+
+# rdepends on weston which depends on virtual/egl
+REQUIRED_DISTRO_FEATURES = "opengl"
RDEPENDS_${PN} = "weston kbd"
INITSCRIPT_NAME = "weston"
INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
+
+SYSTEMD_SERVICE_${PN} = "weston.service"