summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb')
-rw-r--r--yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb
new file mode 100644
index 000000000..156b32948
--- /dev/null
+++ b/yocto-poky/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Common X11 scripts and configuration files"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+SECTION = "x11"
+PR = "r47"
+
+inherit distro_features_check
+# rdepends on xdypinfo xmodmap xinit
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI = "file://etc \
+ file://gplv2-license.patch"
+
+S = "${WORKDIR}"
+
+do_install() {
+ cp -R ${S}/etc ${D}${sysconfdir}
+ chmod -R 755 ${D}${sysconfdir}
+ find ${D}${sysconfdir} -type f -name \*~ -exec rm -rf {} \;
+}
+
+RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor"
+