summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb')
-rw-r--r--yocto-poky/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb b/yocto-poky/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
new file mode 100644
index 000000000..b81f8a3b3
--- /dev/null
+++ b/yocto-poky/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 Intel Corporation. All rights reserved
+#
+
+SUMMARY = "Qt package groups"
+LICENSE = "MIT"
+PR = "r4"
+
+# Qt4 could NOT be built on MIPS64 with 64 bits userspace
+COMPATIBLE_HOST_mips64 = "null"
+
+inherit packagegroup distro_features_check
+
+# The quicky and fotowall requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+
+PACKAGES = "${PN}-demoapps"
+
+QTDEMOS ?= "quicky ${COMMERCIAL_QT} fotowall"
+
+SUMMARY_${PN}-demoapps = "Qt demo applications"
+RDEPENDS_${PN}-demoapps = "${QTDEMOS}"