summaryrefslogtreecommitdiff
path: root/yocto-poky/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'yocto-poky/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb')
-rw-r--r--yocto-poky/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/yocto-poky/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb b/yocto-poky/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb
new file mode 100644
index 000000000..aa1b0b62f
--- /dev/null
+++ b/yocto-poky/meta/recipes-qt/qt-demo/qt-demo-init_0.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Init script for qtdemo"
+LICENSE = "MIT"
+SRC_URI = "file://qtdemo-init"
+PR = "r3"
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/qtdemo-init ${D}${sysconfdir}/init.d/qtdemo
+}
+
+inherit update-rc.d allarch
+
+INITSCRIPT_NAME = "qtdemo"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 19 0 1 6 ."