summaryrefslogtreecommitdiff
path: root/special-mode-mgr/CMakeLists.txt
diff options
context:
space:
mode:
authorRichard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>2019-11-11 09:18:09 +0300
committerThomaiyar, Richard Marian <richard.marian.thomaiyar@intel.com>2019-11-18 19:39:10 +0300
commitd095ccea8df74f9de228ab83b658d80b4fb79460 (patch)
treed2f85643fa86d28cc646883b6756163eba0b47cf /special-mode-mgr/CMakeLists.txt
parentc559e2c659b0d3b6ca76e1553c68ab1960d461d0 (diff)
downloadprovingground-d095ccea8df74f9de228ab83b658d80b4fb79460.tar.xz
Update special mode mgr as per D-Bus interface
Updated special-mode-mgr service to expose the property as per the D-Bus interface SpecialMode in the community Tested 1. Verified that manufacturing mode entered as per 15 second power buttong press during AC cycle 2. Verified that expired based on timeout or restriction mode property change 3. Verified validation unsecure features works as expected Change-Id: I87b67424f657a1a19545b4dc18a80a2fddf8ee44 Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
Diffstat (limited to 'special-mode-mgr/CMakeLists.txt')
-rw-r--r--special-mode-mgr/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/special-mode-mgr/CMakeLists.txt b/special-mode-mgr/CMakeLists.txt
index ea54904..fa69da8 100644
--- a/special-mode-mgr/CMakeLists.txt
+++ b/special-mode-mgr/CMakeLists.txt
@@ -24,6 +24,15 @@ pkg_check_modules(SYSTEMD libsystemd REQUIRED)
# import sdbusplus
find_package(PkgConfig REQUIRED)
pkg_check_modules(SDBUSPLUSPLUS sdbusplus REQUIRED)
+include_directories(${SDBUSPLUSPLUS_INCLUDE_DIRS})
+link_directories(${SDBUSPLUSPLUS_LIBRARY_DIRS})
+find_program(SDBUSPLUSPLUS sdbus++)
+
+# phosphor-dbus-interfaces
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(DBUSINTERFACE phosphor-dbus-interfaces REQUIRED)
+include_directories(${DBUSINTERFACE_INCLUDE_DIRS})
+link_directories(${DBUSINTERFACE_LIBRARY_DIRS})
# import phosphor-logging
find_package(PkgConfig REQUIRED)
@@ -31,7 +40,8 @@ pkg_check_modules(LOGGING phosphor-logging REQUIRED)
add_executable(${PROJECT_NAME} ${SRC_FILES})
target_link_libraries(${PROJECT_NAME} systemd)
-target_link_libraries(${PROJECT_NAME} sdbusplus)
+target_link_libraries(${PROJECT_NAME} ${SDBUSPLUSPLUS_LIBRARIES})
+target_link_libraries(${PROJECT_NAME} ${DBUSINTERFACE_LIBRARIES})
target_link_libraries(${PROJECT_NAME} ${Boost_LIBRARIES})
target_link_libraries(${PROJECT_NAME} phosphor_logging)