summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2018-07-28 02:13:37 +0300
committerEd Tanous <ed.tanous@intel.com>2018-10-09 06:32:58 +0300
commit1da66f7501332d622f64963136f1cba38829fb40 (patch)
treefe3ed3859237eac165e656cadc38c856313b7d62 /CMakeLists.txt
parent3ae837c9180669fd0e96da8862bd7618dd737102 (diff)
downloadbmcweb-1da66f7501332d622f64963136f1cba38829fb40.tar.xz
Implement redfish LogService
This commit implements an optional LogService endpoint for debugging CPUs over Redish. It exposes both the ability to create a new log with the LogImmediate action, as well as to pull a stored log using the LogCollection schema. This feature is disabled by default, and should be enabled in the meta-x86 layer. Change-Id: Ied1d5e263a0857e09cd9a24fddec9c11a4066cd2 Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 97b3aad0c9..dcd174df1b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,16 @@ option (BMCWEB_ENABLE_HOST_SERIAL_WEBSOCKET "Enable host serial websocket" ON)
option (BMCWEB_ENABLE_STATIC_HOSTING "Enable hosting of static files.
For example, redfish schema and webui files" ON)
-# Insecure options. Every option that starts with a BMCWEB_INSECURE flag should
+option (
+ BMCWEB_ENABLE_REDFISH_RAW_PECI "Enable PECI transactions through redfish"
+ OFF
+)
+option (
+ BMCWEB_ENABLE_REDFISH_CPU_LOG
+ "Enable CPU log service transactions through redfish" OFF
+)
+
+# Insecure options.Every option that starts with a BMCWEB_INSECURE flag should
# not be enabled by default for any platform, unless the author fully
# comprehends the implications of doing so. In general, enabling these options
# will cause security problems of varying degrees
@@ -194,7 +203,6 @@ if (${BMCWEB_BUILD_UT})
set_source_files_properties (
${CMAKE_BINARY_DIR}/include/bmcweb/blns.hpp PROPERTIES GENERATED TRUE
)
-
enable_testing ()
add_executable (webtest ${SRC_FILES} ${UT_FILES})