summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 20:05:37 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 04:26:31 +0300
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadopenbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.xz
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch')
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch.inc49
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch/0001-kpatch-build-add-cross-compilation-support.patch103
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch/0002-kpatch-build-allow-overriding-of-distro-name.patch62
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch_git.bb11
4 files changed, 0 insertions, 225 deletions
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch.inc b/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch.inc
deleted file mode 100644
index b1e73e9542..0000000000
--- a/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch.inc
+++ /dev/null
@@ -1,49 +0,0 @@
-SUMMARY = "Linux dynamic kernel patching infrastructure"
-DESCRIPTION = "kpatch is a Linux dynamic kernel patching infrastructure which allows you to patch a running kernel without rebooting or restarting any processes."
-LICENSE = "GPLv2 & LGPLv2"
-DEPENDS = "elfutils bash"
-
-SRC_URI = "git://github.com/dynup/kpatch.git;protocol=https \
- file://0001-kpatch-build-add-cross-compilation-support.patch \
- file://0002-kpatch-build-allow-overriding-of-distro-name.patch \
- "
-
-EXTRA_OEMAKE = " \
- PREFIX=${prefix} \
- BINDIR=${D}${bindir} \
- SBINDIR=${D}${sbindir} \
- LIBDIR=${D}${libdir} \
- MANDIR=${D}${mandir}/man1 \
- SYSTEMDDIR=${D}${systemd_system_unitdir} \
- DESTDIR=${D} \
- BUILDMOD=no \
- CC='${CC}' \
- "
-
-S = "${WORKDIR}/git"
-
-do_install () {
- oe_runmake install
-}
-
-PACKAGES =+ "kpatch-build"
-PROVIDES += "kpatch-build"
-
-COMPATIBLE_HOST = "(x86_64).*-linux"
-
-RDEPENDS_${PN} = "bash binutils"
-RDEPENDS_kpatch-build = "bash glibc-utils"
-
-FILES_${PN} = " \
- ${sbindir}/kpatch \
- ${systemd_system_unitdir}/kpatch.service \
- ${mandir}/man1/kpatch.1.gz \
- "
-FILES_kpatch-build = " \
- ${bindir}/kpatch-build \
- ${libexecdir}/* \
- ${datadir}/kpatch \
- ${mandir}/man1/kpatch-build.1.gz \
- "
-
-SYSTEMD_SERVICE_${PN} = "kpatch.service"
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch/0001-kpatch-build-add-cross-compilation-support.patch b/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch/0001-kpatch-build-add-cross-compilation-support.patch
deleted file mode 100644
index 459fb21977..0000000000
--- a/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch/0001-kpatch-build-add-cross-compilation-support.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-From a9a80a1f4df65892a0269295ce8a64b06f2ff61d Mon Sep 17 00:00:00 2001
-From: Ruslan Bilovol <rbilovol@cisco.com>
-Date: Tue, 19 Dec 2017 15:59:04 +0200
-Subject: [PATCH] kpatch-build: add cross-compilation support
-
-This patch introduces new option for kpatch-build
-script "--cross-compile" which can be used for
-specifying cross-complier prefix.
-It allows to build live patches not only on
-target system, but also on hosts for a target other
-than the one on which the compiler is running
-
-Also removed quotes in exec lines, so it is
-possible to pass multy-component strings like
-"ccache x86_64-xelinux-linux-" as cross-compiler
-
-Upstream-Status: Pending
-
-Signed-off-by: Ruslan Bilovol <rbilovol@cisco.com>
----
- kpatch-build/kpatch-build | 13 +++++++++++--
- kpatch-build/kpatch-gcc | 4 ++--
- 2 files changed, 13 insertions(+), 4 deletions(-)
-
-diff --git a/kpatch-build/kpatch-build b/kpatch-build/kpatch-build
-index 166ecbd..af24cc4 100755
---- a/kpatch-build/kpatch-build
-+++ b/kpatch-build/kpatch-build
-@@ -195,7 +195,7 @@ gcc_version_check() {
- # gcc --version varies between distributions therefore extract version
- # by compiling a test file and compare it to vmlinux's version.
- echo 'void main(void) {}' > "$c"
-- out="$(gcc -c -pg -ffunction-sections -o "$o" "$c" 2>&1)"
-+ out="$(${KPATCH_CROSS_COMPILE}gcc -c -pg -ffunction-sections -o "$o" "$c" 2>&1)"
- gccver="$(gcc_version_from_file "$o")"
- kgccver="$(gcc_version_from_file "$VMLINUX")"
- rm -f "$c" "$o"
-@@ -381,12 +381,14 @@ usage() {
- echo " -d, --debug Enable 'xtrace' and keep scratch files" >&2
- echo " in <CACHEDIR>/tmp" >&2
- echo " (can be specified multiple times)" >&2
-+ echo " --cross-compile Specify the prefix used for all executables" >&2
-+ echo " used during compilation" >&2
- echo " --skip-cleanup Skip post-build cleanup" >&2
- echo " --skip-gcc-check Skip gcc version matching check" >&2
- echo " (not recommended)" >&2
- }
-
--options="$(getopt -o ha:r:s:c:v:j:t:n:o:d -l "help,archversion:,sourcerpm:,sourcedir:,config:,vmlinux:,jobs:,target:,name:,output:,debug,skip-gcc-check,skip-cleanup" -- "$@")" || die "getopt failed"
-+options="$(getopt -o ha:r:s:c:v:j:t:n:o:d -l "help,archversion:,sourcerpm:,sourcedir:,config:,vmlinux:,jobs:,target:,name:,output:,debug,cross-compile:,skip-gcc-check,skip-cleanup" -- "$@")" || die "getopt failed"
-
- eval set -- "$options"
-
-@@ -444,6 +446,10 @@ while [[ $# -gt 0 ]]; do
- echo "DEBUG mode enabled"
- fi
- ;;
-+ --cross-compile)
-+ KPATCH_CROSS_COMPILE="$2"
-+ shift
-+ ;;
- --skip-cleanup)
- echo "Skipping cleanup"
- SKIPCLEANUP=1
-@@ -691,6 +697,8 @@ if [[ $DEBUG -ge 4 ]]; then
- export KPATCH_GCC_DEBUG=1
- fi
-
-+export KPATCH_CROSS_COMPILE
-+
- echo "Building original kernel"
- ./scripts/setlocalversion --save-scmversion || die
- make mrproper 2>&1 | logger || die
-@@ -840,6 +848,7 @@ cd "$TEMPDIR/patch" || die
- KPATCH_BUILD="$SRCDIR" KPATCH_NAME="$MODNAME" \
- KBUILD_EXTRA_SYMBOLS="$KBUILD_EXTRA_SYMBOLS" \
- KPATCH_LDFLAGS="$KPATCH_LDFLAGS" \
-+CROSS_COMPILE="$KPATCH_CROSS_COMPILE" \
- make 2>&1 | logger || die
-
- if ! "$KPATCH_MODULE"; then
-diff --git a/kpatch-build/kpatch-gcc b/kpatch-build/kpatch-gcc
-index 6ba133c..3937948 100755
---- a/kpatch-build/kpatch-gcc
-+++ b/kpatch-build/kpatch-gcc
-@@ -8,7 +8,7 @@ TOOLCHAINCMD="$1"
- shift
-
- if [[ -z "$KPATCH_GCC_TEMPDIR" ]]; then
-- exec "$TOOLCHAINCMD" "$@"
-+ exec ${KPATCH_CROSS_COMPILE}${TOOLCHAINCMD} "$@"
- fi
-
- declare -a args=("$@")
-@@ -80,4 +80,4 @@ elif [[ "$TOOLCHAINCMD" = "ld" ]] ; then
- done
- fi
-
--exec "$TOOLCHAINCMD" "${args[@]}"
-+exec ${KPATCH_CROSS_COMPILE}${TOOLCHAINCMD} "${args[@]}"
---
-1.9.1
-
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch/0002-kpatch-build-allow-overriding-of-distro-name.patch b/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch/0002-kpatch-build-allow-overriding-of-distro-name.patch
deleted file mode 100644
index a9d8a7f2c5..0000000000
--- a/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch/0002-kpatch-build-allow-overriding-of-distro-name.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From d418d716dae1e2a05131dfb42a19a4da2fc8a85d Mon Sep 17 00:00:00 2001
-From: Ruslan Bilovol <rbilovol@cisco.com>
-Date: Tue, 2 Jan 2018 14:50:03 +0200
-Subject: [PATCH] kpatch-build: allow overriding of distro name
-
-It is sometimes useful to have ability to override
-distro name, for example during cross-compilation
-build when livepatch modules will be ran on the
-target which differs from host.
-
-This patch adds a new --distro option which
-implements all needed functionality
-
-Upstream-Status: Pending
-
-Signed-off-by: Ruslan Bilovol <rbilovol@cisco.com>
----
- kpatch-build/kpatch-build | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/kpatch-build/kpatch-build b/kpatch-build/kpatch-build
-index af24cc4..4f9f78d 100755
---- a/kpatch-build/kpatch-build
-+++ b/kpatch-build/kpatch-build
-@@ -383,12 +383,13 @@ usage() {
- echo " (can be specified multiple times)" >&2
- echo " --cross-compile Specify the prefix used for all executables" >&2
- echo " used during compilation" >&2
-+ echo " --distro Override distro name" >&2
- echo " --skip-cleanup Skip post-build cleanup" >&2
- echo " --skip-gcc-check Skip gcc version matching check" >&2
- echo " (not recommended)" >&2
- }
-
--options="$(getopt -o ha:r:s:c:v:j:t:n:o:d -l "help,archversion:,sourcerpm:,sourcedir:,config:,vmlinux:,jobs:,target:,name:,output:,debug,cross-compile:,skip-gcc-check,skip-cleanup" -- "$@")" || die "getopt failed"
-+options="$(getopt -o ha:r:s:c:v:j:t:n:o:d -l "help,archversion:,sourcerpm:,sourcedir:,config:,vmlinux:,jobs:,target:,name:,output:,debug,cross-compile:,distro:,skip-gcc-check,skip-cleanup" -- "$@")" || die "getopt failed"
-
- eval set -- "$options"
-
-@@ -450,6 +451,10 @@ while [[ $# -gt 0 ]]; do
- KPATCH_CROSS_COMPILE="$2"
- shift
- ;;
-+ --distro)
-+ DISTRO="$2"
-+ shift
-+ ;;
- --skip-cleanup)
- echo "Skipping cleanup"
- SKIPCLEANUP=1
-@@ -526,7 +531,7 @@ fi
- # Don't check external file.
- # shellcheck disable=SC1091
- source /etc/os-release
--DISTRO="$ID"
-+DISTRO="${DISTRO:-${ID}}"
- if [[ "$DISTRO" = fedora ]] || [[ "$DISTRO" = rhel ]] || [[ "$DISTRO" = ol ]] || [[ "$DISTRO" = centos ]]; then
- [[ -z "$VMLINUX" ]] && VMLINUX="/usr/lib/debug/lib/modules/$ARCHVERSION/vmlinux"
- [[ -e "$VMLINUX" ]] || die "kernel-debuginfo-$ARCHVERSION not installed"
---
-1.9.1
-
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch_git.bb b/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch_git.bb
deleted file mode 100644
index e495e2882c..0000000000
--- a/import-layers/meta-openembedded/meta-oe/recipes-kernel/kpatch/kpatch_git.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require kpatch.inc
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-
-SRCREV = "db6efbb8c7e90d2b761272cf563047119072768f"
-
-PV = "0.5.0+git${SRCPV}"
-
-S = "${WORKDIR}/git"
-
-BBCLASSEXTEND = "native nativesdk"