summaryrefslogtreecommitdiff
path: root/import-layers/yocto-poky/meta/recipes-graphics/mesa/mesa_17.1.7.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-02-26 06:55:05 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-15 17:22:49 +0300
commitd7bf8c17eca8f8c89898a7794462c773c449e983 (patch)
treed18618fca85ca5f0c077032cc7b009344b60f663 /import-layers/yocto-poky/meta/recipes-graphics/mesa/mesa_17.1.7.bb
parente2b5abdc9f28cdf8578e5b9be803c8e697443c20 (diff)
downloadopenbmc-d7bf8c17eca8f8c89898a7794462c773c449e983.tar.xz
Yocto 2.4
Move OpenBMC to Yocto 2.4(rocko) Tested: Built and verified Witherspoon and Palmetto images Change-Id: I12057b18610d6fb0e6903c60213690301e9b0c67 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'import-layers/yocto-poky/meta/recipes-graphics/mesa/mesa_17.1.7.bb')
-rw-r--r--import-layers/yocto-poky/meta/recipes-graphics/mesa/mesa_17.1.7.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/import-layers/yocto-poky/meta/recipes-graphics/mesa/mesa_17.1.7.bb b/import-layers/yocto-poky/meta/recipes-graphics/mesa/mesa_17.1.7.bb
new file mode 100644
index 0000000000..39cfce992f
--- /dev/null
+++ b/import-layers/yocto-poky/meta/recipes-graphics/mesa/mesa_17.1.7.bb
@@ -0,0 +1,25 @@
+require ${BPN}.inc
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
+ file://replace_glibc_check_with_linux.patch \
+ file://disable-asm-on-non-gcc.patch \
+ file://0001-Use-wayland-scanner-in-the-path.patch \
+ file://0002-hardware-gloat.patch \
+ file://vulkan-mkdir.patch \
+ file://llvm-config-version.patch \
+ file://0001-ac-fix-build-after-LLVM-5.0-SVN-r300718.patch \
+ file://0002-gallivm-Fix-build-against-LLVM-SVN-r302589.patch \
+ file://0001-winsys-svga-drm-Include-sys-types.h.patch \
+ file://0001-configure.ac-Always-check-for-expat.patch \
+ file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
+ "
+SRC_URI[md5sum] = "e40bb428a263bd28cbf6478dae45b207"
+SRC_URI[sha256sum] = "69f472a874b1122404fa0bd13e2d6bf87eb3b9ad9c21d2f39872a96d83d9e5f5"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}