summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-phosphor/hostlogger
diff options
context:
space:
mode:
authorChau Ly <chaul@amperecomputing.com>2023-01-13 06:41:22 +0300
committerChau Ly <chaul@amperecomputing.com>2023-01-13 07:03:44 +0300
commit74946010ffb0b679bdf4341d8e1f012b61181ccc (patch)
tree24b55058bb3fb5ae570ca7040b1d5a0587217f24 /meta-ampere/meta-jade/recipes-phosphor/hostlogger
parent0ea73d38736b6f2dfc1bc42a5b855bef4d016f79 (diff)
downloadopenbmc-74946010ffb0b679bdf4341d8e1f012b61181ccc.tar.xz
meta-ampere: mtjade: Support host consoles logger
This commit supports phosphor-hostlogger in STREAM mode, to forward the byte stream from obmc-console to rsyslog via the imuxsock module. The logs can be obtained in /var/log/. The logs are rotated by logrotate. The size threshold of cpu console is 256KB and the others are 64KB. Each log is polled every 1 minute to check if its file size exceeds the threshold to rotate it to the new file. Each console can be saved in up to 2 log files. Tested (CPU console): 1. Change the mux of CPU console to BMC $ ampere_uartmux_ctrl.sh 1 2 2. Connect to CPU SOL console $ ssh root@<BMC_IP> -p 2200 3. Execute commands in the CPU SOL console => The console output on CPU SOL console will all be logged to /var/log/obmc-console-cpu.log => The log will be rotated to /var/log/obmc-console-cpu.log.1 if the original log file size exceeds 256KB every 1min poll Signed-off-by: Chau Ly <chaul@amperecomputing.com> Change-Id: I5586d1c634ec0f244069b868bd48b75560520dc1
Diffstat (limited to 'meta-ampere/meta-jade/recipes-phosphor/hostlogger')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS0.conf3
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS1.conf3
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS2.conf3
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS3.conf3
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend18
5 files changed, 30 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS0.conf b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS0.conf
new file mode 100644
index 0000000000..e0c10a42ed
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS0.conf
@@ -0,0 +1,3 @@
+# SOCKET-ID is default to obmc-console
+MODE=stream
+STREAM_DST=/run/rsyslog/console/cpu
diff --git a/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS1.conf b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS1.conf
new file mode 100644
index 0000000000..faaf1a458e
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS1.conf
@@ -0,0 +1,3 @@
+SOCKET_ID=ttyS1
+MODE=stream
+STREAM_DST=/run/rsyslog/console/scp0
diff --git a/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS2.conf b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS2.conf
new file mode 100644
index 0000000000..5d3cfb6828
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS2.conf
@@ -0,0 +1,3 @@
+SOCKET_ID=ttyS2
+MODE=stream
+STREAM_DST=/run/rsyslog/console/atf
diff --git a/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS3.conf b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS3.conf
new file mode 100644
index 0000000000..14bfd4b2c1
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger/ttyS3.conf
@@ -0,0 +1,3 @@
+SOCKET_ID=ttyS3
+MODE=stream
+STREAM_DST=/run/rsyslog/console/scp1
diff --git a/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend
new file mode 100644
index 0000000000..38521ade21
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend
@@ -0,0 +1,18 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append = " \
+ file://ttyS0.conf \
+ file://ttyS1.conf \
+ file://ttyS2.conf \
+ file://ttyS3.conf \
+ "
+
+do_install:append() {
+
+ # Install the configurations
+ install -m 0755 -d ${D}${sysconfdir}/${BPN}
+ install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
+
+ # Remove upstream-provided default configuration
+ rm -f ${D}${sysconfdir}/${BPN}/ttyVUART0.conf
+}