summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2020-12-29 10:18:26 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-02-01 16:44:47 +0300
commite9e3d5c76872873b8debdfc80ce7ab42317461b8 (patch)
treee5ba9c1708f953e0bb82a9a8e54840ce57bccd6f /meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
parente37d98b766a26c073d78af823915d4c8b0381559 (diff)
downloadopenbmc-e9e3d5c76872873b8debdfc80ce7ab42317461b8.tar.xz
meta-ampere: mtjade: Enable Redfish support for on-board sensors
Map FAN, temperature and voltage sensors with Redfish chassis instance and enables association feature in phosphor-inventory-manager. The bmcweb looks for the sensors associated with a chassis instance in the association list. The list, which is associations.json file in phosphor-inventory-manager, maps the dbus sensor objects to a chassis inventory. Tested: 1. Check power/voltage sensors reported in redfish/v1/Chassis/chassis/Power. 2. Check FANs/thermal sensors reported in redfish/v1/Chassis/chassis/Thermal. Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: Ie62a1c1a4edeaf165f834f7456c26711b4b42701
Diffstat (limited to 'meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
new file mode 100644
index 0000000000..a8856809b6
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -0,0 +1,10 @@
+DEPENDS_append_mtjade = " inventory-cleanup"
+
+FILESEXTRAPATHS_prepend_mtjade := "${THISDIR}/${PN}:"
+PACKAGECONFIG_append_mtjade = " associations"
+SRC_URI_append_mtjade = " file://associations.json"
+
+do_install_append_mtjade() {
+ install -d ${D}${base_datadir}
+ install -m 0755 ${WORKDIR}/associations.json ${D}${base_datadir}
+}