summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-mitchell
diff options
context:
space:
mode:
authorHieu Huynh <hieuh@os.amperecomputing.com>2024-01-27 17:20:55 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2024-01-28 07:02:59 +0300
commitc0bc385a845ea93f5b56dbd5c86db3246e6f9f31 (patch)
treec17382a5c93d2882f3a0cb090d462dbd7f8294b1 /meta-ampere/meta-mitchell
parent95a21774eaf13e04e859d0c42abf9699a3315605 (diff)
downloadopenbmc-c0bc385a845ea93f5b56dbd5c86db3246e6f9f31.tar.xz
meta-ampere: mtmitchell: update LED configuration file name
phosphor-led-manager is changed to use xyz.openbmc_project.Inventory. Decorator.Compatible interface to select the configuration file. This updates the led-group-config.json file to com.ampere.Hardware.Chassis.Model.MtMitchell.json follow the phosphor-led-manager. Tested: verify that led config file in the system root@mtmitchell-dcscm:~# ls /usr/share/phosphor-led-manager/ com.ampere.Hardware.Chassis.Model.MtMitchell.json com.ibm.Hardware.Chassis.Model.Rainier1S4U.json com.ibm.Hardware.Chassis.Model.Rainier4U.json com.ibm.Hardware.Chassis.Model.Everest.json com.ibm.Hardware.Chassis.Model.Rainier2U.json Signed-off-by: Hieu Huynh <hieuh@os.amperecomputing.com> Change-Id: Id7a2f885a933319b8b09279689dfb627c843cf88
Diffstat (limited to 'meta-ampere/meta-mitchell')
-rw-r--r--meta-ampere/meta-mitchell/conf/machine/mtmitchell.conf2
-rw-r--r--meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager/com.ampere.Hardware.Chassis.Model.MtMitchell.json (renamed from meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager/led-group-config.json)0
-rw-r--r--meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager_%.bbappend4
3 files changed, 4 insertions, 2 deletions
diff --git a/meta-ampere/meta-mitchell/conf/machine/mtmitchell.conf b/meta-ampere/meta-mitchell/conf/machine/mtmitchell.conf
index 7bf86d0fdd..3b40661ff9 100644
--- a/meta-ampere/meta-mitchell/conf/machine/mtmitchell.conf
+++ b/meta-ampere/meta-mitchell/conf/machine/mtmitchell.conf
@@ -14,6 +14,8 @@ require conf/distro/include/pldm.inc
FLASH_SIZE = "65536"
VOLATILE_LOG_DIR = "no"
+OBMC_COMPATIBLE_NAMES = "com.ampere.Hardware.Chassis.Model.MtMitchell"
+
MACHINE_FEATURES += "\
obmc-bmc-state-mgmt \
obmc-chassis-state-mgmt \
diff --git a/meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager/led-group-config.json b/meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager/com.ampere.Hardware.Chassis.Model.MtMitchell.json
index 098c3fdb65..098c3fdb65 100644
--- a/meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager/led-group-config.json
+++ b/meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager/com.ampere.Hardware.Chassis.Model.MtMitchell.json
diff --git a/meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager_%.bbappend b/meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
index 7e8821f157..10427a2749 100644
--- a/meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
+++ b/meta-ampere/meta-mitchell/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI += " file://led-group-config.json"
+SRC_URI += " file://com.ampere.Hardware.Chassis.Model.MtMitchell.json"
do_install:append() {
- install -m 0644 ${WORKDIR}/led-group-config.json ${D}${datadir}/phosphor-led-manager/
+ install -m 0644 ${WORKDIR}/com.ampere.Hardware.Chassis.Model.MtMitchell.json ${D}${datadir}/phosphor-led-manager/
}