summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-greatlakes/recipes-greatlakes/greatlakes-sysinit/greatlakes-sysinit.bb
diff options
context:
space:
mode:
authorDelphine CC Chiu <Delphine_CC_Chiu@wiwynn.com>2023-02-22 08:17:37 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-03-03 18:46:13 +0300
commitbed86692c269433864d801d77d14180fceb4a16a (patch)
tree7485c768241451b966ff1abc9a9e9d2b3bd1e4bf /meta-facebook/meta-greatlakes/recipes-greatlakes/greatlakes-sysinit/greatlakes-sysinit.bb
parent0823bd2e6b84b30cd1ee537205df1edbe833cb46 (diff)
downloadopenbmc-bed86692c269433864d801d77d14180fceb4a16a.tar.xz
meta-facebook: greatlakes: System state initialization
Description: - System state initialization. Design: - Use script to determine 12V and host current state 12V: use BMC gpio host: Use BIC gpio - Set correct state on CurrentHostState property for host status - Set correcr state on CurrentPowerState property for 12V status Test Case: 1. 12V on and host off 2. 12V on and host on 3. 12V off and host off Signed-off-by: Delphine CC Chiu <Delphine_CC_Chiu@wiwynn.com> Change-Id: Ibff1f6e79290cfb39dc5442c240e324b38c18ecd
Diffstat (limited to 'meta-facebook/meta-greatlakes/recipes-greatlakes/greatlakes-sysinit/greatlakes-sysinit.bb')
-rw-r--r--meta-facebook/meta-greatlakes/recipes-greatlakes/greatlakes-sysinit/greatlakes-sysinit.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-facebook/meta-greatlakes/recipes-greatlakes/greatlakes-sysinit/greatlakes-sysinit.bb b/meta-facebook/meta-greatlakes/recipes-greatlakes/greatlakes-sysinit/greatlakes-sysinit.bb
new file mode 100644
index 0000000000..716251ed7d
--- /dev/null
+++ b/meta-facebook/meta-greatlakes/recipes-greatlakes/greatlakes-sysinit/greatlakes-sysinit.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Initialize system state"
+DESCRIPTION = "Initialize system state"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit pkgconfig
+inherit systemd
+inherit obmc-phosphor-systemd
+
+RDEPENDS:${PN} += "bash"
+
+SRC_URI += " \
+ file://greatlakes-system-state-init \
+ file://greatlakes-system-state-init@.service \
+ "
+
+do_install() {
+ install -d ${D}${libexecdir}/${PN}
+ install -m 0755 ${WORKDIR}/greatlakes-system-state-init ${D}${libexecdir}/${PN}/
+}
+
+TGT = "${SYSTEMD_DEFAULT_TARGET}"
+GREATLAKES_SYS_ST_INIT_INSTFMT="../greatlakes-system-state-init@.service:${TGT}.wants/greatlakes-system-state-init@{0}.service"
+
+SYSTEMD_SERVICE:${PN} += "greatlakes-system-state-init@.service"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'GREATLAKES_SYS_ST_INIT_INSTFMT', 'OBMC_HOST_INSTANCES')}"