summaryrefslogtreecommitdiff
path: root/meta-facebook/meta-tiogapass
diff options
context:
space:
mode:
authorLogananth Sundararaj <logananth_s@hcl.com>2022-03-22 15:00:16 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-03-22 19:35:59 +0300
commite1cea2c36a971167d087548488f3365c3d232434 (patch)
treeca1475a5d334dd04bcf6642c9cdc3751ad74aa7c /meta-facebook/meta-tiogapass
parentede195794e600f0b67899fe695bf2407416f877f (diff)
downloadopenbmc-e1cea2c36a971167d087548488f3365c3d232434.tar.xz
meta-facebook: meta-tiogapass: switch u-boot to 2019.04
Switching the u-boot branch from the 2016.07-aspeed-openbmc to the 2019.04-aspeed-openbmc Added the config file to modify the defconfig file from the uboot-machine. Removing the files related to the 2016.07-aspeed branch. Tested: Tested in Tiogapass platform and Verified the U-boot logs. Signed-off-by: Logananth Sundararaj <logananth_s@hcl.com> Change-Id: I5caadacdc1232fc180db79abe2f11c959feca018
Diffstat (limited to 'meta-facebook/meta-tiogapass')
-rw-r--r--meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf9
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed-sdk/tiogapass.cfg5
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch39
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend2
7 files changed, 14 insertions, 47 deletions
diff --git a/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf b/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf
index 0c78afcacf..55773fcec1 100644
--- a/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf
+++ b/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf
@@ -1,11 +1,12 @@
KMACHINE = "aspeed"
KERNEL_DEVICETREE = "${KMACHINE}-bmc-facebook-${MACHINE}.dtb"
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-aspeed"
-PREFERRED_PROVIDER_u-boot = "u-boot-aspeed"
-PREFERRED_PROVIDER_u-boot-fw-utils = "u-boot-fw-utils-aspeed"
+PREFERRED_PROVIDER_virtual/bootloader = "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot = "u-boot-aspeed-sdk"
+PREFERRED_PROVIDER_u-boot-fw-utils = "u-boot-fw-utils-aspeed-sdk"
-UBOOT_MACHINE = "ast_g5_ncsi_config"
+UBOOT_DEVICETREE = "ast2500-evb"
+UBOOT_MACHINE = "evb-ast2500_defconfig"
require conf/machine/include/facebook-compute-singlehost.inc
require conf/machine/include/ast2500.inc
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed-sdk/tiogapass.cfg b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed-sdk/tiogapass.cfg
new file mode 100644
index 0000000000..6cc537edbe
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed-sdk/tiogapass.cfg
@@ -0,0 +1,5 @@
+CONFIG_USE_BOOTARGS=y
+CONFIG_BOOTARGS="console=ttyS4,57600n8 root=/dev/ram rw"
+CONFIG_USE_BOOTCOMMAND=y
+CONFIG_BOOTCOMMAND="bootm 20080000"
+CONFIG_BAUDRATE=57600
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
new file mode 100644
index 0000000000..8089fdcd1e
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://tiogapass.cfg"
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch
deleted file mode 100644
index 4bec6c8d52..0000000000
--- a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed/0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 44cdd36855728059e58dcad52b42d825bb1cc2af Mon Sep 17 00:00:00 2001
-From: Paul Fertser <fercerpav@gmail.com>
-Date: Fri, 25 Sep 2020 18:36:45 +0300
-Subject: [PATCH] configs/ast-common: use 57600 baud rate to match Tioga Pass
- EFI firmware
-
-This is a Tioga Pass specific patch, only for
-meta-facebook/meta-tiogapass layer.
-
-Signed-off-by: Paul Fertser <fercerpav@gmail.com>
----
- include/configs/ast-common.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/configs/ast-common.h b/include/configs/ast-common.h
-index a0243083bd..f0f2ae08b6 100644
---- a/include/configs/ast-common.h
-+++ b/include/configs/ast-common.h
-@@ -56,7 +56,7 @@
- #define CONFIG_SYS_LOADS_BAUD_CHANGE
- #define CONFIG_SERIAL1 1
- #define CONFIG_CONS_INDEX 1
--#define CONFIG_BAUDRATE 115200
-+#define CONFIG_BAUDRATE 57600
-
- /*
- * BOOTP options
-@@ -96,7 +96,7 @@
- #define CONFIG_CMD_MTDPARTS
- #endif
-
--#define CONFIG_BOOTARGS "console=ttyS4,115200n8 root=/dev/ram rw"
-+#define CONFIG_BOOTARGS "console=ttyS4,57600n8 root=/dev/ram rw"
-
- #define CONFIG_AST_SPI_NOR /* AST SPI NOR Flash */
- #define CONFIG_FMC_CS 1
---
-2.17.1
-
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
deleted file mode 100644
index db85451db4..0000000000
--- a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-aspeed_%.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch"
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend
new file mode 100644
index 0000000000..0cca3de3ba
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-aspeed-sdk:"
+SRC_URI += "file://tiogapass.cfg"
diff --git a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend b/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend
deleted file mode 100644
index d66a385e62..0000000000
--- a/meta-facebook/meta-tiogapass/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_%.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-aspeed:"
-SRC_URI += "file://0001-configs-ast-common-use-57600-baud-rate-to-match-Tiog.patch"