summaryrefslogtreecommitdiff
path: root/meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
diff options
context:
space:
mode:
authorKumar Thangavel <thangavel.k@hcl.com>2021-02-17 10:36:10 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-04-07 22:16:51 +0300
commit76202e16f8ab80774060fe0d36f31a8e667ed691 (patch)
treed036f9c174c7e6dc7cb38ac63c6289623a0b5537 /meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
parent88cb23d1d705f4158d7869a98fca9c8da3799324 (diff)
downloadopenbmc-76202e16f8ab80774060fe0d36f31a8e667ed691.tar.xz
Add Airflow virtual sensor support
Added support in the machine layer for Airflow sensor as virtual sensor. TESTED : Built Facebook YosemiteV2 images and loaded on the target hardware. Verified the airflow sensor values in the phosphor-virtual-sensor dbus objects. Signed-off-by: Kumar Thangavel <thangavel.k@hcl.com> Change-Id: I46b377cc119a31f76286ba2d03f14764f578283f
Diffstat (limited to 'meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend')
-rw-r--r--meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend b/meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
new file mode 100644
index 0000000000..94650bab6a
--- /dev/null
+++ b/meta-facebook/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+
+SRC_URI_append = " file://${MACHINE}_sensor_config.json"
+
+do_install_append() {
+
+ install -d ${D}/usr/share/phosphor-virtual-sensor
+
+ install -m 0644 -D ${WORKDIR}/${MACHINE}_sensor_config.json \
+ ${D}/usr/share/phosphor-virtual-sensor/virtual_sensor_config.json
+}