summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorAllen.Wang <Allen_Wang@quantatw.com>2022-01-26 05:54:09 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-01-26 23:28:28 +0300
commit8941818183bc33da1154d2c0b3e9fe15353ea53b (patch)
tree458b9fd1725321fea1db06757c818b014da14dfc /meta-facebook
parentdedf1abb4f26f858dbf7882ee57456922e8f34c0 (diff)
downloadopenbmc-8941818183bc33da1154d2c0b3e9fe15353ea53b.tar.xz
meta-bletchley: motor-ctrl: Make init services auto start
We want to do motor-init and turn on ac when system boot-up, make service instances link under /lib/systemd/system/multi-user.target.wants/ Change-Id: I53bc97270d111b90e0d70052f81a7e428805ead1 Signed-off-by: Allen.Wang <Allen_Wang@quantatw.com>
Diffstat (limited to 'meta-facebook')
-rw-r--r--meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb
index ba682880f3..41e0ce9f15 100644
--- a/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb
+++ b/meta-facebook/meta-bletchley/recipes-bletchley/motor-ctrl/motor-ctrl_0.1.bb
@@ -25,10 +25,11 @@ do_install() {
install -m 0755 ${WORKDIR}/motor-init ${D}${libexecdir}
}
-MOTOR_INIT_INSTFMT="motor-init-calibration@.service:motor-init-calibration@{0}.service"
+TGT = "${SYSTEMD_DEFAULT_TARGET}"
+MOTOR_INIT_INSTFMT="../motor-init-calibration@.service:${TGT}.wants/motor-init-calibration@{0}.service"
PWR_ON_INSTFMT="host-poweron@.service:host-poweron@{0}.service"
PWR_OFF_INSTFMT="host-poweroff@.service:host-poweroff@{0}.service"
-AC_ON_INSTFMT="host-ac-on@.service:host-ac-on@{0}.service"
+AC_ON_INSTFMT="../host-ac-on@.service:${TGT}.wants/host-ac-on@{0}.service"
AC_OFF_INSTFMT="host-ac-off@.service:host-ac-off@{0}.service"
SYSTEMD_SERVICE:${PN} += "motor-init-calibration@.service"