summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-08-11 15:15:51 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-08-11 20:05:31 +0300
commit9cf368fdb46223d6a23594648b887dcdc3c20bfc (patch)
tree1d3c8e43011f19af0ce7e4046e24be343bf1a0d2 /meta-facebook
parent945f241df1083753a00a1b567c3e41d6a7593f1c (diff)
downloadopenbmc-9cf368fdb46223d6a23594648b887dcdc3c20bfc.tar.xz
meta-facebook: fix fb-ipmi-oem config for bic
The meson flags for BIC were inverted. BIC was "enabled" on most systems and "disabled" on Yv2. Switch to a PACKAGECONFIG and set all `fb-compute-multihost` to enable BIC by default. Change-Id: If5335c95cf148664b9e5724d2646d646a0f3d4c3
Diffstat (limited to 'meta-facebook')
-rwxr-xr-xmeta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
index b722a76b01..3d4f9128fa 100755
--- a/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
+++ b/meta-facebook/recipes-fb/ipmi/fb-ipmi-oem_git.bb
@@ -14,9 +14,16 @@ DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd "
inherit meson pkgconfig obmc-phosphor-ipmiprovider-symlink
-EXTRA_OEMESON="-Dtests=disabled -Dbic=enabled -Dhost-instances='${OBMC_HOST_INSTANCES}'"
-EXTRA_OEMESON:remove:yosemitev2 = "-Dbic=enabled"
-EXTRA_OEMESON="-Dmachine='${MACHINE}'"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG:fb-compute-multihost ??= "bic"
+
+PACKAGECONFIG[bic] = "-Dbic=enabled,-Dbic=disabled"
+
+EXTRA_OEMESON="\
+ -Dtests=disabled \
+ -Dmachine='${MACHINE}' \
+ -Dhost-instances='${OBMC_HOST_INSTANCES}' \
+ "
LIBRARY_NAMES = "libzfboemcmds.so"