summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorPotin Lai <potin.lai@quantatw.com>2022-08-16 08:01:26 +0300
committerPotin Lai <potin.lai@quantatw.com>2022-08-16 16:50:50 +0300
commitd418bed49ebf43f0c51ca9e1a5783fb924072205 (patch)
tree89e20ba9dc19c0e003c2ac49b1e6a1af3fef791e /meta-facebook
parent1163ccef7c14363d710a9c10435192fdc61f29b0 (diff)
downloadopenbmc-d418bed49ebf43f0c51ca9e1a5783fb924072205.tar.xz
meta-bletchley: bsp: convert patch to cfg file
convert current patch to .cfg file Signed-off-by: Potin Lai <potin.lai@quantatw.com> Change-Id: I98ad0d5d69dd0c55ea40debd5b05ba4aa77be945
Diffstat (limited to 'meta-facebook')
-rw-r--r--meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch31
-rw-r--r--meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/bletchley.cfg3
-rw-r--r--meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend5
-rw-r--r--meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend5
4 files changed, 5 insertions, 39 deletions
diff --git a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch
deleted file mode 100644
index 46f8929085..0000000000
--- a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 12e9371e44b922e0383dba3a231a21b82ca03368 Mon Sep 17 00:00:00 2001
-From: Howard <howard.chiu@quantatw.com>
-Date: Wed, 4 Aug 2021 14:08:14 +0800
-Subject: [PATCH] u-boot: ast2600: 57600 baudrate for bletchley
-
-Specific patch for bletchley only
----
- configs/ast2600_openbmc_spl_defconfig | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/configs/ast2600_openbmc_spl_defconfig b/configs/ast2600_openbmc_spl_defconfig
-index c1ed4f54d5..2257673e16 100644
---- a/configs/ast2600_openbmc_spl_defconfig
-+++ b/configs/ast2600_openbmc_spl_defconfig
-@@ -35,7 +35,7 @@ CONFIG_ARMV7_PSCI_NR_CPUS=2
- CONFIG_NR_DRAM_BANKS=1
- CONFIG_FIT=y
- CONFIG_USE_BOOTARGS=y
--CONFIG_BOOTARGS="console=ttyS4,115200n8 root=/dev/ram rw"
-+CONFIG_BOOTARGS="console=ttyS4,57600n8 root=/dev/ram rw"
- CONFIG_USE_BOOTCOMMAND=y
- CONFIG_BOOTCOMMAND="bootm 20100000"
- CONFIG_SYS_CONSOLE_ENV_OVERWRITE=y
-@@ -133,3 +133,4 @@ CONFIG_USE_TINY_PRINTF=y
- CONFIG_TPM=y
- CONFIG_SPL_TPM=y
- # CONFIG_EFI_LOADER is not set
-+CONFIG_BAUDRATE=57600
---
-2.25.1
-
diff --git a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/bletchley.cfg b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/bletchley.cfg
new file mode 100644
index 0000000000..cd6f2db3fc
--- /dev/null
+++ b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk/bletchley.cfg
@@ -0,0 +1,3 @@
+CONFIG_USE_BOOTARGS=y
+CONFIG_BOOTARGS="console=ttyS4,57600n8 root=/dev/ram rw"
+CONFIG_BAUDRATE=57600
diff --git a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
index d526638c0b..d8c7b61b96 100644
--- a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
+++ b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-aspeed-sdk_%.bbappend
@@ -1,5 +1,2 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += " \
- file://0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch \
- "
+SRC_URI +="file://bletchley.cfg"
diff --git a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend
index c9401d1776..de2bc5055d 100644
--- a/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend
+++ b/meta-facebook/meta-bletchley/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_%.bbappend
@@ -1,5 +1,2 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-aspeed-sdk:"
-
-SRC_URI += " \
- file://0001-u-boot-ast2600-57600-baudrate-for-bletchley.patch \
- "
+SRC_URI +="file://bletchley.cfg"