summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorPotin Lai <potin.lai@quantatw.com>2024-01-05 10:46:23 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-01-05 21:16:15 +0300
commit2c35d0ddeedc2e3796450b72d007486be696b1b2 (patch)
tree7879c82250b9f59d07407f5dfd49024d63ed749c /meta-facebook
parent885c5d0a0aa55862eef4f5020ee93472501c8eaf (diff)
downloadopenbmc-2c35d0ddeedc2e3796450b72d007486be696b1b2.tar.xz
meta-facebook: fix remote-addr type in ipmb-channels.json
ipmbbridged only allow remote-addr as integer. Convert remote-addr from string to integer. Tested On Harma: ``` root@harma:~# cat /usr/share/ipmbbridge/ipmb-channels.json { "channels": [ { "type": "ipmb", "slave-path": "/dev/ipmb-14", "bmc-addr": 32, "remote-addr": 96, "devIndex": 0 } ] } root@harma:~# systemctl status ipmb * ipmb.service - IPMB bridge Loaded: loaded (/usr/lib/systemd/system/ipmb.service; enabled; preset: enabled) Active: active (running) since Thu 2024-01-04 22:54:48 PST; 1h 3min ago Main PID: 425 (ipmbbridged) CPU: 4.887s CGroup: /system.slice/ipmb.service `-425 /usr/bin/ipmbbridged Jan 04 22:54:48 harma systemd[1]: Started IPMB bridge. ``` Signed-off-by: Potin Lai <potin.lai@quantatw.com> Change-Id: I9823d3e6d219737c6426880d1a9fbaa407cd9c75
Diffstat (limited to 'meta-facebook')
-rw-r--r--meta-facebook/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-facebook/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend b/meta-facebook/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
index e0723321b7..5bf23d1f8a 100644
--- a/meta-facebook/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
+++ b/meta-facebook/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
@@ -14,7 +14,7 @@ python do_ipmb_channels() {
"type": "ipmb",
"slave-path": ipmb_channel[i],
"bmc-addr": 32,
- "remote-addr": ipmb_remote_addr[i] if i < len(ipmb_remote_addr) else 64,
+ "remote-addr": int(ipmb_remote_addr[i]) if i < len(ipmb_remote_addr) else 64,
"devIndex": i
})