summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-02-17 16:30:57 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-02-18 21:41:12 +0300
commitd5c716dc3add128301ec4ba8ebb21bb6eb7856fd (patch)
treeec3dcdc3ab942a2beac6b9207f3a8506bfaa34af /meta-facebook
parent18a6b18c34b9c651b96fa3fb5be956aee1604db9 (diff)
downloadopenbmc-d5c716dc3add128301ec4ba8ebb21bb6eb7856fd.tar.xz
treewide: fix append/remove directives
As mentioned by I970e06ca6f9d0a9792af122eb25da1bb9a06f058, append and remove directives with '+=' are no longer valid Yocto syntax and raise a warning. See https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n40 One interesting caveat has to do with the difference between "append" and "+=". foo:append = "a" foo:append = "b" Results in `foo = "ab"`, but foo += "a" foo += "b" Results in `foo = "a b"`. When `:append +=` is used it has behavior like the `+=` operator. Therefore, in some cases we need to insert additional whitespace after the `:append = "` to ensure concatenation behaves as expected. I've manually reviewed the results to ensure there is no ill side-effects from an additional space potentially being added. Fix up the entire tree with the following one-liner (and similar for `remove`): git ls-files -- ':!:poky/**' ':!:meta-security/**' \ ':!:meta-raspberrypi/**' ':!:meta-openembedded/**' \ | grep "\.bb" | xargs grep -l ":append.*+=" \ | xargs sed -i 's/:append\(.*\)+=\([^"]*\)" */:append\1=\2" /' or ... | xargs grep -l ":remove.*+=" \ | xargs sed -i "s/:remove\(.*\)+=/:remove\1=/" Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Iea6235e7c76e252f4d473652957c2925f6b8845a
Diffstat (limited to 'meta-facebook')
-rw-r--r--meta-facebook/recipes-phosphor/datetime/phosphor-time-manager_%.bbappend4
-rw-r--r--meta-facebook/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend6
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-facebook/recipes-phosphor/datetime/phosphor-time-manager_%.bbappend b/meta-facebook/recipes-phosphor/datetime/phosphor-time-manager_%.bbappend
index 97ea50d800..0e4429ecbf 100644
--- a/meta-facebook/recipes-phosphor/datetime/phosphor-time-manager_%.bbappend
+++ b/meta-facebook/recipes-phosphor/datetime/phosphor-time-manager_%.bbappend
@@ -1,9 +1,9 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI:append:fb-withhost += "file://set-bmc-time-from-host"
+SRC_URI:append:fb-withhost = " file://set-bmc-time-from-host"
-RDEPENDS:${PN}:append:fb-withhost += "bash"
+RDEPENDS:${PN}:append:fb-withhost = " bash"
do_install:append:fb-withhost(){
diff --git a/meta-facebook/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend b/meta-facebook/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend
index 8ae2e609ec..3ee26b1efe 100644
--- a/meta-facebook/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend
+++ b/meta-facebook/recipes-phosphor/hostlogger/phosphor-hostlogger_%.bbappend
@@ -2,9 +2,9 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://ttyS2.conf"
-SRC_URI:append:yosemitev2 += "file://ttyS0.conf"
-SRC_URI:append:yosemitev2 += "file://ttyS1.conf"
-SRC_URI:append:yosemitev2 += "file://ttyS3.conf"
+SRC_URI:append:yosemitev2 = " file://ttyS0.conf"
+SRC_URI:append:yosemitev2 = " file://ttyS1.conf"
+SRC_URI:append:yosemitev2 = " file://ttyS3.conf"
do_install:append() {