summaryrefslogtreecommitdiff
path: root/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend
diff options
context:
space:
mode:
authorCharles Boyer <Charles.Boyer@fii-usa.com>2021-08-24 19:25:03 +0300
committerCharles Boyer <Charles.Boyer@fii-usa.com>2021-11-09 01:10:53 +0300
commit1c51ca54c8206feaeaea61c1e4831b4a68ddb0e5 (patch)
tree8f986e6717079f8bc3a5f3f49babf2c41ebe31a1 /meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend
parentc6001349529450007d0430377fca88ca11d3a71e (diff)
downloadopenbmc-1c51ca54c8206feaeaea61c1e4831b4a68ddb0e5.tar.xz
meta-fii/meta-kudo: Fix power control states and timing
Summary of changes: 1. Adjust start time of xyz.openbmc_project.State.Chassis.service to fix initial chassis state 2. Add shutdown ack service 3. Remove reset ack service 4. Remove heartbeat mode 5. Remove sysreset pin control from power_control.exe 6. Remove all phosphor-fan services that caused power off during a system reset 7. Adjustments to ampere_power_util.sh (See below) ampere_power_util.sh: 1. Use GPIO instead of dbus for host state 2. Wait 3 seconds before checking power status for power on 3. Wait 6 seconds before checking power status for power off 4. Have force_off act GPIO while power_off sets Chassis state 5. Graceful shutdown acts GPIO 6. Check host status before issuing system reset 7. Set Watchdog Expire Action to None before power off and reset Signed-off-by: Charles Boyer <Charles.Boyer@fii-usa.com> Change-Id: Ie2720ee60d489c4160165c6827a78a400ae4d30b
Diffstat (limited to 'meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend')
-rw-r--r--meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend
new file mode 100644
index 0000000000..57e3aa6c8a
--- /dev/null
+++ b/meta-fii/meta-kudo/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS:prepend:kudo := "${THISDIR}/${PN}:"
+
+SRC_URI:append:kudo = " \
+ file://xyz.openbmc_project.State.Chassis.service \
+ "
+
+do_install:append:kudo() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/xyz.openbmc_project.State.Chassis.service ${D}${systemd_system_unitdir}/xyz.openbmc_project.State.Chassis.service
+}
+