summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2022-05-10 01:24:22 +0300
committerWilliam A. Kennington III <wak@google.com>2022-05-27 02:02:20 +0300
commitd230e86a920ba1440e6299a60f0442ceb610d500 (patch)
treef9ca0e3f85f289f1b0c59ff0a6fd887cdb8fa622 /meta-google
parent83f9416eee4289606fb6a297f095cf583a875e7f (diff)
downloadopenbmc-d230e86a920ba1440e6299a60f0442ceb610d500.tar.xz
meta-google: gbmc-bridge: Add DHCP coalesced powercycle
This makes it possible to perform to coalesce multiple powercycles into a single one. Change-Id: I748219a037e38b617b8d662eff498fd3b37acbb6 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge.bb4
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge/50-gbmc-psu-hardreset.sh37
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-bridge.bb b/meta-google/recipes-google/networking/gbmc-bridge.bb
index 57f78ea4ac..850b14a237 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge.bb
+++ b/meta-google/recipes-google/networking/gbmc-bridge.bb
@@ -21,6 +21,7 @@ SRC_URI += " \
file://gbmc-br-gw-src.sh \
file://gbmc-br-nft.sh \
file://gbmc-br-dhcp.sh \
+ file://50-gbmc-psu-hardreset.sh \
file://gbmc-br-dhcp.service \
file://gbmc-br-dhcp-term.sh \
file://gbmc-br-dhcp-term.service \
@@ -28,6 +29,7 @@ SRC_URI += " \
FILES:${PN}:append = " \
${datadir}/gbmc-ip-monitor \
+ ${datadir}/gbmc-br-dhcp \
${systemd_unitdir}/network \
${sysconfdir}/nftables \
${sysconfdir}/avahi/services \
@@ -109,6 +111,8 @@ do_install() {
install -m0644 ${WORKDIR}/gbmc-br-ensure-ra.service ${D}${systemd_system_unitdir}/
install -m0644 ${WORKDIR}/gbmc-br-dhcp.service ${D}${systemd_system_unitdir}/
install -m0644 ${WORKDIR}/gbmc-br-dhcp-term.service ${D}${systemd_system_unitdir}/
+ install -d -m0755 ${D}${datadir}/gbmc-br-dhcp
+ install -m0644 ${WORKDIR}/50-gbmc-psu-hardreset.sh ${D}${datadir}/gbmc-br-dhcp/
}
do_rm_work:prepend() {
diff --git a/meta-google/recipes-google/networking/gbmc-bridge/50-gbmc-psu-hardreset.sh b/meta-google/recipes-google/networking/gbmc-bridge/50-gbmc-psu-hardreset.sh
new file mode 100644
index 0000000000..c0974a00d1
--- /dev/null
+++ b/meta-google/recipes-google/networking/gbmc-bridge/50-gbmc-psu-hardreset.sh
@@ -0,0 +1,37 @@
+#!/bin/bash
+# Copyright 2022 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+[ -n "${gbmc_psu_hardreset-}" ] && return
+
+gbmc_psu_hardreset_needed=
+
+gbmc_psu_hardreset_hook() {
+ # We don't always need a powercycle, allow skipping
+ if [ -z "${gbmc_psu_hardreset_needed-}" ]; then
+ echo "Skipping tray powercycle" >&2
+ return 0
+ fi
+
+ echo "Powercycling" >&2
+ systemctl start gbmc-psu-hardreset.target || return
+
+ # Ensure that we don't continue the DHCP process while waiting for the
+ # powercycle.
+ exit 0
+}
+
+GBMC_BR_DHCP_HOOKS+=(gbmc_psu_hardreset_hook)
+
+gbmc_psu_hardreset=1