summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2022-05-25 04:52:03 +0300
committerWilliam A. Kennington III <wak@google.com>2022-05-27 04:23:12 +0300
commit5a8202c3b37a2187f2521e494875f0db133f31b5 (patch)
treea529e3ddd2b1ebcd1f91a92cdd7937b549b4ad76 /meta-google
parent1a756aedde1da56e839d745c9ddac53d75be64b7 (diff)
downloadopenbmc-5a8202c3b37a2187f2521e494875f0db133f31b5.tar.xz
meta-google: gbmc-update: Migrate to curl
We want to remove wget from busybox so we need an alternate fetcher. Tested: Ran locally against an installer URL to verify the behavior Change-Id: Ib3a00002d7d2d02bd6b29e24f0dbe2c7c9243514 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-phosphor/flash/gbmc-update.bb2
-rw-r--r--meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh5
-rw-r--r--meta-google/recipes-support/curl/curl_%.bbappend1
3 files changed, 6 insertions, 2 deletions
diff --git a/meta-google/recipes-phosphor/flash/gbmc-update.bb b/meta-google/recipes-phosphor/flash/gbmc-update.bb
index 2c0f51066a..c0a3f7a9e8 100644
--- a/meta-google/recipes-phosphor/flash/gbmc-update.bb
+++ b/meta-google/recipes-phosphor/flash/gbmc-update.bb
@@ -11,6 +11,8 @@ SRC_URI += " \
FILES:${PN} += "${datadir}/gbmc-br-dhcp"
+RDEPENDS:${PN} += "curl"
+
do_install() {
install -d ${D}${datadir}/gbmc-br-dhcp
install -m 0644 ${WORKDIR}/75-gbmc-upgrade.sh ${D}${datadir}/gbmc-br-dhcp/
diff --git a/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh b/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh
index 1ed4b9a22c..f002b22c77 100644
--- a/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh
+++ b/meta-google/recipes-phosphor/flash/gbmc-update/75-gbmc-upgrade.sh
@@ -46,10 +46,11 @@ gbmc_upgrade_fetch() (
# Ensure some sane output file limit
# Currently no BMC image is larger than 64M
ulimit -H -f $((96 * 1024 * 1024)) || return
- timeout=$((SECONDS + 120))
+ timeout=$((SECONDS + 300))
while (( SECONDS < timeout )); do
local st=(0)
- wget -q -O - "$bootfile_url" | tar -xC "$tmpdir" "firmware-gbmc/$machine" || st=("${PIPESTATUS[@]}")
+ curl -LSsk --max-time $((timeout - SECONDS)) "$bootfile_url" |
+ tar -xC "$tmpdir" "firmware-gbmc/$machine" || st=("${PIPESTATUS[@]}")
(( st[0] != 0 )) || break
(shopt -s nullglob dotglob; rm -rf -- "${tmpdir:?}"/*)
sleep 5
diff --git a/meta-google/recipes-support/curl/curl_%.bbappend b/meta-google/recipes-support/curl/curl_%.bbappend
new file mode 100644
index 0000000000..9037946c74
--- /dev/null
+++ b/meta-google/recipes-support/curl/curl_%.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG:remove = "libidn"