summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorYuxiao Zhang <yuxiaozhang@google.com>2023-03-31 01:55:30 +0300
committerYuxiao Zhang <yuxiaozhang@google.com>2023-04-11 19:15:12 +0300
commit8fe218a0ec92f3a788ecd5e68eb84e02a2ec7d75 (patch)
tree3ad01616ad9e0a70415402e8bbcb5719e425068d /meta-google
parent4b4958048b30f5f9d3163dc1b7e53b359e5e94aa (diff)
downloadopenbmc-8fe218a0ec92f3a788ecd5e68eb84e02a2ec7d75.tar.xz
meta-google: dhcp-done: switching to new dhcp-done service
We want to coordinate with netboot server for powercycling instead of triggering pwercycle ourselves. dhcp-done will send status based on the parameters to the netboot server. This is the first part, second part needs to be merged after installer support Change-Id: I4ebaaf06114fc36518a25cdc6cd9f093859963c8 Signed-off-by: Yuxiao Zhang <yuxiaozhang@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/google-misc/google-misc.inc2
-rw-r--r--meta-google/recipes-google/networking/dhcp-done_git.bb2
-rw-r--r--meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-google/recipes-google/google-misc/google-misc.inc b/meta-google/recipes-google/google-misc/google-misc.inc
index df7e79bbb9..1198065b5f 100644
--- a/meta-google/recipes-google/google-misc/google-misc.inc
+++ b/meta-google/recipes-google/google-misc/google-misc.inc
@@ -6,7 +6,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://../../LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
SRC_URI += "git://github.com/openbmc/google-misc;branch=master;protocol=https"
-SRCREV = "273640137fb68c352babd03e77018d426d7cc93c"
+SRCREV = "5ca20ffedd60cf6b25eec734a1ac340b6f60e015"
S = "${WORKDIR}/git/subprojects/${GOOGLE_MISC_PROJ}"
inherit meson pkgconfig
diff --git a/meta-google/recipes-google/networking/dhcp-done_git.bb b/meta-google/recipes-google/networking/dhcp-done_git.bb
index 5732033153..12e3903837 100644
--- a/meta-google/recipes-google/networking/dhcp-done_git.bb
+++ b/meta-google/recipes-google/networking/dhcp-done_git.bb
@@ -6,7 +6,7 @@ require ../google-misc/google-misc.inc
inherit systemd
-SYSTEMD_SERVICE:${PN} += "dhcp-done.service"
+SYSTEMD_SERVICE:${PN} += "dhcp-done@.service"
DEPENDS += " \
sdeventplus \
diff --git a/meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh b/meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh
index f4ac5a5a53..6557125a9e 100644
--- a/meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh
+++ b/meta-google/recipes-google/networking/gbmc-bridge/gbmc-br-dhcp.sh
@@ -76,5 +76,5 @@ if [ "$1" = bound ]; then
# Ensure that the installer knows we have completed processing DHCP by
# running a service that reports completion
echo 'Start DHCP Done' >&2
- systemctl start dhcp-done --no-block
+ systemctl start dhcp-done@DONE --no-block
fi