summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2022-04-05 03:54:01 +0300
committerWilliam A. Kennington III <wak@google.com>2022-04-06 01:48:59 +0300
commita68422b555ac8abd917383be57cb71a937672686 (patch)
tree4662739b99e6f9fba4c6f74b4f7f7244f7f9d94d /meta-google
parent69ebd2cebd2a16a116163400831920c757542cfd (diff)
downloadopenbmc-a68422b555ac8abd917383be57cb71a937672686.tar.xz
meta-google: google-usb-network: Allow specifying interface name
Change-Id: Icdf1b12993b96d13008ddae93a54aa5bd6b35173 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/networking/google-usb-network/usb_network.service.m42
-rw-r--r--meta-google/recipes-google/networking/google-usb-network_git.bb2
2 files changed, 3 insertions, 1 deletions
diff --git a/meta-google/recipes-google/networking/google-usb-network/usb_network.service.m4 b/meta-google/recipes-google/networking/google-usb-network/usb_network.service.m4
index cefaff9400..252f4093fc 100644
--- a/meta-google/recipes-google/networking/google-usb-network/usb_network.service.m4
+++ b/meta-google/recipes-google/networking/google-usb-network/usb_network.service.m4
@@ -21,7 +21,7 @@ ExecStart=M_SCRIPT_INSTALL_DIR/usb_network.sh \
--dev-type "M_BMC_USB_TYPE" \
HOST_MAC_ARG(M_BMC_USB_HOST_MAC) \
DEV_MAC_ARG(M_BMC_USB_DEV_MAC) \
- --iface-name usb0 \
+ --iface-name "M_BMC_USB_IFACE" \
--bind-device "M_BMC_USB_BIND_DEV"
ExecStop=M_SCRIPT_INSTALL_DIR/usb_network.sh stop
diff --git a/meta-google/recipes-google/networking/google-usb-network_git.bb b/meta-google/recipes-google/networking/google-usb-network_git.bb
index 882b755f8e..9ba7c529fa 100644
--- a/meta-google/recipes-google/networking/google-usb-network_git.bb
+++ b/meta-google/recipes-google/networking/google-usb-network_git.bb
@@ -26,6 +26,7 @@ BMC_USB_ECM_BIND_DEV ??= ""
BMC_USB_CONFIG_PRIORITY ??= ""
BMC_USB_CONFIG_FILENAME ??= "${BMC_USB_CONFIG_PRIORITY}-bmc-usb0.network"
BMC_USB_TYPE ??= "eem"
+BMC_USB_IFACE ??= "gusb0"
SRC_URI += "file://00-bmc-usb0.network.m4"
SRC_URI += "file://usb_network.service.m4"
@@ -48,6 +49,7 @@ do_compile() {
-DM_BMC_USB_TYPE="${BMC_USB_TYPE}" \
-DM_BMC_USB_HOST_MAC="${BMC_USB_ECM_HOST_MAC}" \
-DM_BMC_USB_DEV_MAC="${BMC_USB_ECM_DEV_MAC}" \
+ -DM_BMC_USB_IFACE="${BMC_USB_IFACE}" \
-DM_BMC_USB_BIND_DEV="${BMC_USB_ECM_BIND_DEV}" \
-DM_SCRIPT_INSTALL_DIR="${bindir}" \
${WORKDIR}/usb_network.service.m4 > ${S}/usb_network.service