summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilly Tu <wltu@google.com>2022-03-28 21:18:53 +0300
committerWilly Tu <wltu@google.com>2022-03-29 17:04:19 +0300
commitc93f10bdd66f21d740071703bc6112e0051f647d (patch)
tree73f3eeb0a658ff424d1430b747ae674394226a28 /meta-google
parent6ccf04fd02d9f81e38b14b2861cf5d5764bb6be2 (diff)
downloadopenbmc-c93f10bdd66f21d740071703bc6112e0051f647d.tar.xz
meta-google: Set entiy-map to `[]` by default for gBMC
The entity map is now used for ipmid/dbus-sdr and will cause ipmi failures after https://gerrit.openbmc-project.xyz/c/openbmc/phosphor-host-ipmid/+/46882 Remove the default json and only allow system that require it to override it. Tested: ``` $ cat ./tmp/work/all-openbmc-linux/phosphor-ipmi-config/1.0-r1/package/usr/share/ipmi-providers/entity-map.json [] ``` Change-Id: I0ef8248a0d7d99fa0c9e3199c4eceb664bc624cf Signed-off-by: Willy Tu <wltu@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend b/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
index 56f7933d43..aa2e266718 100644
--- a/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
+++ b/meta-google/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
@@ -18,5 +18,9 @@ do_install:append:gbmc() {
jq --slurpfile brcfg ${WORKDIR}/gbmc_bridge.json \
'. + {"${GBMCBR_IPMI_CHANNEL}": $brcfg[0]}' $chjson >${WORKDIR}/tmp
mv ${WORKDIR}/tmp $chjson
+
+ # Set entity-map.json to empty json for gBMC by default.
+ # Each system will override it if needed.
+ echo "[]" > ${D}${datadir}/ipmi-providers/entity-map.json
}