summaryrefslogtreecommitdiff
path: root/meta-hpe/meta-dl360poc/recipes-hpe/host
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-04-14 22:29:45 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-04-20 14:36:29 +0300
commit8b86a4153fd24d74a87aa19141a0c8ebd1b23b80 (patch)
tree2f7df401696203c4655bb3e265fd77657953e685 /meta-hpe/meta-dl360poc/recipes-hpe/host
parent861ed8f3b21666fe471f33f1f737faca70898ebd (diff)
downloadopenbmc-8b86a4153fd24d74a87aa19141a0c8ebd1b23b80.tar.xz
meta-hpe: fix shellcheck issues
Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I30885f8c2577c3c2aa333a61210e6738fbf016c7
Diffstat (limited to 'meta-hpe/meta-dl360poc/recipes-hpe/host')
-rw-r--r--meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable.bbappend1
-rw-r--r--meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable/host-boot-enable.sh14
2 files changed, 8 insertions, 7 deletions
diff --git a/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable.bbappend b/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable.bbappend
index 4fc41d0580..e8b0ea6dcc 100644
--- a/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable.bbappend
+++ b/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable.bbappend
@@ -1 +1,2 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+RDEPENDS:${PN}:append = " bash"
diff --git a/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable/host-boot-enable.sh b/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable/host-boot-enable.sh
index 08b882d6d2..bff898d7f8 100644
--- a/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable/host-boot-enable.sh
+++ b/meta-hpe/meta-dl360poc/recipes-hpe/host/host-boot-enable/host-boot-enable.sh
@@ -1,10 +1,10 @@
-#!/bin/sh
+#!/bin/bash
findmtd() {
m=$(grep -xl "$1" /sys/class/mtd/*/name)
m=${m%/name}
m=${m##*/}
- echo $m
+ echo "$m"
}
rom_lists=(host-prime host-second vrom-prime vrom-second)
@@ -12,24 +12,24 @@ rom_mtd_list=()
for f in "${rom_lists[@]}"
do
- image=$(findmtd ${f})
+ image=$(findmtd "${f}")
if test -z "$image"
then
echo "Unable to find mtd partition for ${f}"
exit 1
fi
- rom_mtd_list+=($image)
+ rom_mtd_list+=("$image")
done
#enable vrom
# host-prime to vrom-prime
-dd if=/dev/${rom_mtd_list[0]} of=/dev/${rom_mtd_list[2]}
+dd if="/dev/${rom_mtd_list[0]}" of="/dev/${rom_mtd_list[2]}"
# host-second to vrom-second
-dd if=/dev/${rom_mtd_list[1]} of=/dev/${rom_mtd_list[3]}
+dd if="/dev/${rom_mtd_list[1]}" of="/dev/${rom_mtd_list[3]}"
echo 0x1800008a > /sys/class/soc/srom/vromoff
-while [ true ]
+while true
do
devmem 0x8000005C 8 0
devmem 0xd1000306 8 5